ZCMU 1035 A Multiplication Game

1035: A Multiplication Game

Time Limit: 1 Sec Memory Limit: 128 MB
Submit: 447 Solved: 223
[Submit][Status][Web Board]

Description

Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 231 and the winner is who first reaches p >= n.

Input

Each line of input contains one integer number n.

Output

For each line of input output one line either

Stan wins.

or

Ollie wins.

assuming that both of them play perfectly.

Sample Input

162
17
34012226

Sample Output

Stan wins.
Ollie wins.
Stan wins.

博弈题,就很容易看出如果数在2-9之内那么肯定是Stan赢,超过9,那么stan必定选2,也就是说在10–92内,ollie必胜;
超过18,s就可以通过控制第一次的取值来获胜,最大就是9
2*9;我们可以看到。
每乘18就会循环一轮所以只需要让n不断除以18,最后判断是落在1–9还是10–18里就可以了,由于存在除不尽的情况,需要将n设置为double

Code:

#include <stdio.h>
int main()
{
    double n;
    while(~scanf("%lf",&n))
    {
        while(n>18)n/=18;
        if(n>=1&&n<=9)
            printf("Stan wins.\n");
        else
            printf("Ollie wins.\n");
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值