HDU 1503 Advanced Fruits————LCS(最长公共子序列)变形之字符串合并

The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them.
A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property.

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example.

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names.

Input

Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.

Input is terminated by end of file.

Output

For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.

Sample Input

apple peach
ananas banana
pear peach

Sample Output

appleach
bananas
pearch

 

思路:

要求把两个字符串合并,规则就是两字符的公共子序列中的字符只打印一遍,其他不重复的都各自打印出来。

方法就是求两者最长公共子序列时,对dp数组进行回溯,并且输出每一个经过的字符,具体如图所示。

对于样例

apple peach

经过LCS的dp数组如图所示,设立一个mark数组记录每一个状态的来源状态,例如dp[1][2]就是来源dp[0][1](因为有相同字符p,所以dp[i][j] = dp[i-1][j-1] + 1),用Mark数组记录它的来源是左上角。一共三种来源情况:1 左上, 2 上, 3 左。

然后,在从最左上的到最右下的顺序,输出的经过的字符(该维度变化对应的字符)。

 

 

#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<string>
#include<iostream>
#include<stack>
#include<queue>
#include<algorithm>
#include<map>
#include<list>
#include<vector>

#define INF 0x3f3f3f3f
#define MAXN 1003

using namespace std;

char a[MAXN], b[MAXN];
int dp[MAXN][MAXN], mark[MAXN][MAXN];

void LCS()
{
    int i, j;
    int lena = strlen(a), lenb = strlen(b);
    for(i = 1; i <= lena; i++)
    {
        for(j = 1; j <= lenb; j++)
        {
            if(a[i-1] == b[j-1])
            {
                dp[i][j] = dp[i-1][j-1]+1;
                mark[i][j] = 1;
            }
            else
            {
                if(dp[i-1][j] > dp[i][j-1])
                {
                    dp[i][j] = dp[i-1][j];
                    mark[i][j] = 2;
                }
                else
                {
                    dp[i][j] = dp[i][j-1];
                    mark[i][j] = 3;
                }
            }
        }
    }
}

void Print(int i, int j)
{
    if(i == 0 && j == 0)
    {
        return;
    }
    else if(i == 0 && j != 0)
    {
        Print(i, j-1);
        printf("%c", b[j-1]);
    }
    else if(i != 0 && j == 0)
    {
        Print(i-1, j);
        printf("%c", a[i-1]);
    }

    if(mark[i][j] == 1)
    {
        Print(i-1, j-1);
        printf("%c", a[i-1]);
    }
    else if(mark[i][j] == 2)
    {
        Print(i-1, j);
        printf("%c", a[i-1]);
    }
    else if(mark[i][j] == 3)
    {
        Print(i, j-1);
        printf("%c", b[j-1]);
    }
}

int main()
{
    while(scanf("%s%s", a, b) != EOF)
    {
        memset(dp, 0, sizeof(dp));
        memset(mark, 0, sizeof(mark));
        int lena = strlen(a), lenb = strlen(b);
        LCS();
        Print(lena, lenb);
        printf("\n");
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值