1021 Deepest Root (25 point(s))

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤10
​4
​​ ) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes’ numbers.

Output Specification:
For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:
5
1 2
1 3
1 4
2 5
Sample Output 1:
3
4
5
Sample Input 2:
5
1 3
1 4
2 5
3 4
Sample Output 2:
Error: 2 components
Author
CHEN, Yue
Organization
浙江大学
Code Size Limit
16 KB
Time Limit
2000 ms
Memory Limit
64 MB

先用并查集统计连通块数量(使用DFS统计亦可)
dfs一次找到最深的根节点,再从其中一个根节点dfs一次,两次结果的并集即为所求,原理懒得看

#include<bits/stdc++.h>
using namespace std;
const int maxv=10010;
vector<int> Adj[maxv];
int father[maxv];
int isRoot[maxv]={false},vis[maxv]={false};
int n,maxH=0;
vector<int> temp;
set<int> ans;
int findFather(int x){
    int a=x;
    while(x!=father[x]) x=father[x];
    while(a!=father[a]){
        father[a]=x;
        a=father[a];
    }
    return x;
}
void Union(int a,int b){
    int faA=findFather(a);
    int faB=findFather(b);
    if(faA!=faB) father[faA]=faB;
}
void init(){
    for(int i=1;i<=n;++i){
        father[i]=i;
    }
}
void DFS(int u,int hight){
    if(hight>maxH){
        temp.clear();
        temp.push_back(u);
        maxH=hight;
    }else if(hight==maxH){
        temp.push_back(u);
    }
    vis[u]=true;
    for(int i=0;i<Adj[u].size();++i){
        if(vis[Adj[u][i]]==false)
            DFS(Adj[u][i],hight+1);
    }
}
int main(){
    scanf("%d",&n);
    int a,b;
    for(int i=0;i<n-1;++i){
        scanf("%d%d",&a,&b);
        Adj[a].push_back(b);
        Adj[b].push_back(a);
    }
    init();
    for(int i=1;i<=n;++i){
        for(int j=0;j<Adj[i].size();++j){
            int u=i,v=Adj[i][j];
            Union(u,v);
        }
    }
    int block=0;
    for(int i=1;i<=n;++i){
        int fa=findFather(i);
        if(!isRoot[fa]){
            isRoot[fa]=true;
            block++;
        }
    }
    if(block>1){
        printf("Error: %d components\n",block);
    }else{
        DFS(1,1);
        for(int i=0;i<temp.size();++i)
            ans.insert(temp[i]);
        temp.clear();
        memset(vis,false,sizeof(vis));
        DFS(*ans.begin(),1);
        for(int i=0;i<temp.size();++i)
            ans.insert(temp[i]);
        for(auto it=ans.begin();it!=ans.end();++it)
            printf("%d\n",*it);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值