PAT甲级1039

题目

1039 Course List for Student (25 分)
  Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

  Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N​i(≤200) are given in a line. Then in the next line, N​i student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

  For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

文章大意

  给出学生总数和课程总数,以及每个课程对应的学生名单。让你输出每个学生名单上的课程。课程用编号123代替

思路

  考虑到每个学生都有对应的课程,学生又不同,选用map表示学生和对应的课程,这样输入的时候遍历每个课程的时候,只需要把学生名字存入key,课程编号存入对应的value。然后因为课程有很多,最后输出要排序,选用set表示课程。

实现

#include <iostream>
#include <stdio.h>
#include <unordered_map>
#include <algorithm>
#include <set>
using namespace std;

int main()
{
    int n, m;
    scanf("%d%d", &n, &m);
    unordered_map<string, set<int>> arr;//课程用set表示
    for (int i = 0; i < m; i++) {
        int a, b;
        b = 0;
        cin >> a>> b ;
        for (int i = 0; i < b; i++) {
            string name;
            cin >> name;
            arr[name].insert(a);//对应的名字存入课程
        }
    }
    string s;
    while(cin>>s){
        cout << s << " "<< arr[s].size();//输出名字和课程总数
        for (auto it2 = arr[s].begin(); it2 != arr[s].end(); it2++) {
                cout << " " << *it2;//输出课程
        }
        cout << endl;
    }
}

注意事项

1.当学生没有课程时,输出0
2.采用不排序的map

收获

1.可以这样扩展图的value值:map<string, set<int>> arr;
2.采用while(cin>>s) 可以自动结束输入
3.atuo可以自动识别类型
4.要记住容器的排序是begin()end()跟数组不一样
5.和vector不同,set是不可以通过下标访问的,访问必须使用迭代器,迭代器也不能加数字,好像是指针类型,只能++ --和*,比较也只能== !=
继续冲冲冲!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值