1058 选择题 (20 分)测试点3

1058 选择题 (20 分)
批改多选题是比较麻烦的事情,本题就请你写个程序帮助老师批改多选题,并且指出哪道题错的人最多。

输入格式:
输入在第一行给出两个正整数 N(≤ 1000)和 M(≤ 100),分别是学生人数和多选题的个数。随后 M 行,每行顺次给出一道题的满分值(不超过 5 的正整数)、选项个数(不少于 2 且不超过 5 的正整数)、正确选项个数(不超过选项个数的正整数)、所有正确选项。注意每题的选项从小写英文字母 a 开始顺次排列。各项间以 1 个空格分隔。最后 N 行,每行给出一个学生的答题情况,其每题答案格式为 (选中的选项个数 选项1 ……),按题目顺序给出。注意:题目保证学生的答题情况是合法的,即不存在选中的选项数超过实际选项数的情况。

输出格式:
按照输入的顺序给出每个学生的得分,每个分数占一行。注意判题时只有选择全部正确才能得到该题的分数。最后一行输出错得最多的题目的错误次数和编号(题目按照输入的顺序从 1 开始编号)。如果有并列,则按编号递增顺序输出。数字间用空格分隔,行首尾不得有多余空格。如果所有题目都没有人错,则在最后一行输出 Too simple。

输入样例:
3 4
3 4 2 a c
2 5 1 b
5 3 2 b c
1 5 4 a b d e
(2 a c) (2 b d) (2 a c) (3 a b e)
(2 a c) (1 b) (2 a b) (4 a b d e)
(2 b d) (1 e) (2 b c) (4 a b c d)
输出样例:
3
6
5
2 2 3 4

代码如下:

#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<string.h>
#include<cmath>
#include<map>
#include<vector>
#include<queue>
#include<stack>
#include<iostream>

using namespace std;

const int max_n = 10006;

struct question
{
    int max;
    char answer[6];
    int right;
    int wrong;
}question[101];


int main()
{
    int n,m;
    int a;
    char c;
    scanf("%d %d", &n, &m);
    for (int i = 1; i <= m; i++)
    {
        int k;
        scanf("%d %d %d",&question[i].max,&question[i].right,&k);
        getchar();
        for (int j = 1; j <= k; j++)
        {
            char ans;
            scanf("%c", &ans);
            getchar();
            question[i].answer[j] = ans;
        }
    }
    for (int i = 1; i <= n; i++)
    {
        int score = 0;
        for (int j = 1; j <= m; j++)//m道题
        {
            bool right = true;
            scanf("(%d ", &a);
            for (int i = 1; i <= a; i++)
            {
                scanf("%c", &c);
                getchar();
                if (c != question[j].answer[i])
                {
                    right = false;
                }
            }
            getchar();
            if (right == true)score += question[j].max;
            else question[j].wrong++;
        }
        printf("%d\n", score);
    }
    int max = 0;
    vector<int> pro;
    for (int j = 1; j <= m; j++)
    {
        if (question[j].wrong > max)
        {
            max = question[j].wrong;
            pro.clear();
            pro.push_back(j);
        }
        else if (question[j].wrong == max)
        {
            pro.push_back(j);
        }
    }
    if (max == 0)
    {
        printf("Too simple");
    }
    else
    {
        printf("%d", max);
        for (int i = 0; i < pro.size(); i++)
        {
            printf(" %d", pro[i]);
        }
    }
    
    return 0;
}

总结
不知道哪里出问题了,测试点3一直过不去,过段时间再回来找问题。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值