1160 Forever (20 分)测试点2、3

1160 Forever (20 分)

“Forever number” is a positive integer A with K digits, satisfying the following constrains:

the sum of all the digits of A is m;
the sum of all the digits of A+1 is n; and
the greatest common divisor of m and n is a prime number which is greater than 2.
Now you are supposed to find these forever numbers.

Input Specification:
Each input file contains one test case. For each test case, the first line contains a positive integer N (≤5). Then N lines follow, each gives a pair of K (3<K<10) and m (1<m<90), of which the meanings are given in the problem description.

Output Specification:
For each pair of K and m, first print in a line Case X, where X is the case index (starts from 1). Then print n and A in the following line. The numbers must be separated by a space. If the solution is not unique, output in the ascending order of n. If still not unique, output in the ascending order of A. If there is no solution, output No Solution.

Sample Input:
2
6 45
7 80
Sample Output:
Case 1
10 189999
10 279999
10 369999
10 459999
10 549999
10 639999
10 729999
10 819999
10 909999
Case 2
No Solution

代码如下:

#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<cmath>
#include<map>
#include<vector>
#include<queue>
#include<stack>
#include<set>
#include<iostream>



using namespace std;

const int max_n = 10006;
const int INF = 0x3fffffff;

int N,M,K;


struct info
{
	vector<int> xulie;
	int n, a;
	info()
	{
		n = a = 0;
	}
	info(vector<int> q, int x, int y)
	{
		xulie = q;
		n = x;
		a = y;
	}
}information;

vector<info> ans;

vector<int> tempans;


int gcd(int a, int b)
{
	
	if (b==0)
	{
		return a;
	}
	return gcd(b,a%b);
}

bool isPrime(int x)
{
	if (x <= 2)return false;
	int k = sqrt(1.0 * x);
	for (int i =2; i <= k; i++)
	{
		if (x % i == 0)return false;
	}
	return true;
}

int qiuhe(int x)
{
	int sum=0;
	while (x)
	{
		sum += x % 10;
		x /= 10;
	}
	return sum;
}

void dfs(int cur_dig_num,int cur_dig_sum,int cur_A)
{
	if (cur_dig_num>K|| cur_dig_sum>M)
	{
		return;
	}

	if (cur_dig_num == K&& cur_dig_sum==M)
	{
		int n = qiuhe(cur_A + 1);
		int common = gcd(cur_dig_sum, n);
		
		if (isPrime(common))
		{
			//tempans.push_back(n);
			//info adads(tempans, n, cur_A);
			ans.push_back(info(tempans,n,cur_A));
			//ans.push_back(adads)
			//tempans.pop_back();
		}
		return;
	}
	if (cur_dig_num < K &&(K- cur_dig_num)*9+ cur_dig_sum>=M)
	{
		int A = cur_A * 10;
		for (int i = 0; i <= 9; i++)
		{
			tempans.push_back(i);
			dfs(cur_dig_num + 1, cur_dig_sum + i,A+i);
			tempans.pop_back();
		}
	}
	
}

bool cmp(info aaa, info bbb)
{
	if (aaa.n != bbb.n)return aaa.n < bbb.n;
	else return aaa.a < bbb.a;
}

int main()
{
	cin >> N;
	for (int i = 1; i <= N; i++)
	{
		cin >> K >> M;//k个数字 总和为m
		ans.clear();
		for (int i = 1; i <= 9; i++)
		{
			tempans.push_back(i);
			dfs( 1,  i,i);
			tempans.pop_back();
		}

		printf("Case %d\n", i);
		if (ans.size())
		{
			/*for (int j = 0; j < ans.size(); j++)
			{
				int chang = ans[j].size() - 1;
				printf("%d ", ans[j][chang]);
				for (int k = 0; k < chang; k++)
				{
					printf("%d", ans[j][k]);
				}
				printf("\n");
			}*/
			sort(ans.begin(), ans .end(), cmp);
			for (int j = 0; j < ans.size(); j++)
			{
				printf("%d ", ans[j].n);
				for (int k = 0; k < ans[j].xulie.size(); k++)
				{
					printf("%d", ans[j].xulie[k]);
				}
				printf("\n");
			}
		}
		else
		{
			printf("No Solution\n");
		}
	}

    return 0;
}

总结

测试点2答案错误是因为题目输出要求If the solution is not unique, output in the ascending order of n. If still not unique, output in the ascending order of A(如果解不唯一,则按n的升序输出。如果仍然不唯一,则按A的升序输出),测试点3超时问题是因为当时没有剪枝

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值