A Simple Math Problem

Problem Description

Given two positive integers a and b,find suitable X and Y to meet the conditions:
X+Y=a
Least Common Multiple (X, Y) =b

Input

Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2*104),b(1≤b≤109),and their meanings are shown in the description.Contains most of the 12W test cases.

Output

For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of “No Solution”(without quotation).

Sample Input

6 8
798 10780

Sample Output

No Solution
308 490

化简得(a-x)* x=b * gcd(a-x,x)。然后一元二次方程组求解就好了

#include <bits/stdc++.h>
#define ll long long
using namespace std;
int main(){
    ll n,m;
    ll x,y;
    ll b,c,t;
    while(~scanf("%I64d%I64d",&n,&m)){
        ll z=__gcd(n,m);
        c=m/z;
        b=n/z;
        int flag=0;

        ll data=sqrt(b*b-4*c);
        if(data*data==b*b-4*c){
            t=(b-data)/2;
            if(t*2==b-data) flag=1;
        }
        if(flag){
            cout<<t*z<<" "<<n-t*z<<endl;
        }else{
            cout<<"No Solution"<<endl;
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值