Wireless Network (无线网络) POJ - 2236

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. "O p" (1 <= p <= N), which means repairing computer p.
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

题意:
因为地震,所有电脑都损坏,给出n个电脑的位置坐标,然后说明只有在有限距离内两台电脑才能相互连接,一系列操作之后,多次询问。 
操作包括两种: 1.成功修复一台电脑。O +序号。 
                          2.询问x和y电脑是否相连。 S  x y。 如果能连通输出SUCCESS,否则输出FAIL


题解:(并查集)
给出一个修复好的电脑,就把它和所有可以连接的电脑连在一起


 

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
int f[1010],p[1010][2];
bool dis[1010][1010],m[1010];
int n;
void init()
{
    for(int i=1; i<=n; i++)
        f[i]=i;
}
int getf(int v)
{
    if(f[v]==v)
        return v;
    else
    {
        f[v]=getf(f[v]);
        return f[v];
    }
}
void merge(int x,int y)
{
    int t1=getf(x);
    int t2=getf(y);
    if(t1!=t2)
        f[t2]=t1;
}
int main()
{
    int d;
    memset(dis,0,sizeof(dis));
    memset(m,0,sizeof(m));
    scanf("%d%d",&n,&d);
    init();
    for(int i=1; i<=n; i++)
    {
        scanf("%d%d",&p[i][0],&p[i][1]);//电脑的坐标
    }
    for(int i=1; i<=n; i++)
    {
        for(int j=i; j<=n; j++)
        {
            long long t;
            t=((p[i][0]-p[j][0])*(p[i][0]-p[j][0])+(p[i][1]-p[j][1])*(p[i][1]-p[j][1]));
            if(t<=d*d)
                dis[i][j]=dis[j][i]=1;
        }
    }
    char s;
    while(cin>>s)
    {
        if(s=='O')
        {
            int x;
            scanf("%d",&x);
            m[x]=1;
            for(int i=1; i<=n; i++)
            {
                if(i!=x&&m[i]==1&&dis[i][x]==1)
                    merge(i,x);
            }
        }
        if(s=='S')
        {
            int x,y;
            scanf("%d%d",&x,&y);
            if(getf(x)==getf(y))
                printf("SUCCESS\n");
            else
                printf("FAIL\n");
        }
    }
    return 0;
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值