【 POJ - 1703 】D - Find them, Catch them (种类/分类 并查集)

题目:

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

  1. D [a] [b]
    where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

  2. A [a] [b]
    where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message “A [a] [b]” in each case, your program should give the judgment based on the information got before. The answers might be one of “In the same gang.”, “In different gangs.” and “Not sure yet.”

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

刚接触种类并查集,可能理解还不是很透彻。

种类并查集:多开一倍的数组,例如总人数n,用1+n表示1的对立,2+n表示2的对立,以此类推。

若1 和 2 为对立面,那么1和2+n ( 2 的对立面) 为一个集合,大概类似于“敌人的敌人是朋友”。


代码:

#include <iostream>
#include <cstdio> 
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn=100005;
int t,n,m,father[maxn+maxn],a,b;
char c;
 
int find(int x){  //找根,路径压缩
	return x==father[x]?x:father[x]=find(father[x]);
}

void init() //初始化
{
	for(int i=1;i<maxn+maxn;i++)
	   father[i]=i;
}

void Union(int a,int b){ //合并
	int fa=find(a);
	int fb=find(b);
	if(fa!=fb) father[fb]=fa;
}

int main()
{
 	scanf("%d",&t);
 	while(t--)
 	{
 		scanf("%d%d",&n,&m);
 		init();
 		while(m--)
 		{
 			getchar(); 
 			scanf("%c%d%d",&c,&a,&b);
 			if(c=='D') //a和b是对立面
 			{
 					Union(a,b+n); //a和b+n(b的对立面)
					Union(b,a+n);
			}	
			else if(c=='A')  //询问a和b的关系
			{
				if(find(a)!=find(b) && find(a)!=find(b+n)) //非友非敌
				printf("Not sure yet.\n");
				else if(find(a)==find(b)) printf("In the same gang.\n");//友
				else printf("In different gangs.\n"); //敌
			}
		}
	}
    return 0;
}

在这里插入图片描述

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值