1107 Social Clusters(并查集)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:
Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format

Output Specification:
For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

题意:输入正整数n,表示有n个人,接下来输出每个人的喜爱的活动。判断总共有几个圈子以及每个圈子有多少人(降序输出)

分析:并查集模板题init,findfather,union。主要是求每个圈子的人数。
1、开一个数组course[h]记录每个人喜欢的活动,course[j] = i 表示 i 喜欢活动 j,注意,如果之前没有人喜欢过,那么就course[t] = i. findfather(course[j])就是喜欢这个活动的人的社交圈的根结点,所以把i 与 findfather(course[j])合并。
2、isRoot[i]表示是不是根结点,如果不等于0,则isRoot[findFather(i)]++,总人数就是isRoot中不为0的个数

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1010;
int father[maxn];
int course[maxn] = {0};
int isRoot[maxn] = {0};


void init(int n)    //初始化
{
    for(int i = 1; i <= n; i++)
    {
        father[i] = i;
        isRoot[i] = false;
    }
}


int findFather(int x)   //寻找根结点
{
    int a = x;
    while(x != father[x])
        x = father[x];
    while(a != father[a])
    {
        int z = a;
        a = father[a];
        father[z] = x;
    }
    return x;
}

int Union(int a, int b)     //合并
{
    int faA = findFather(a);
    int faB = findFather(b);
    if(faA != faB)
        father[faA] = faB;
}

bool cmp(int a, int b)      
{
    return a > b;
}
int main()
{
    int n, k, h;        
    scanf("%d", &n);    //人数
    init(n);    //记得初始化
    for(int i = 1; i <= n; i++)     //对每个人
    {   
        scanf("%d:", &k);       //活动个数
        for(int j = 0; j < k; j++)  //对每个活动
        {
            scanf("%d", &h);    //输入i号人喜欢的活动h
            if(course[h] == 0)  //如果活动h第一次有人喜欢
                course[h] = i;  //令i喜欢活动h
            Union(i, findFather(course[h]));    //合并
        }
    }
    for(int i = 1; i <= n; i++)
        isRoot[findFather(i)]++;    //人数加1
    int ans = 0;
    for(int i = 1; i <= n; i++)
        if(isRoot[i] != 0)      //只统计root不为0的
            ans++;
    printf("%d\n", ans);        //输出集合个数
    sort(isRoot + 1, isRoot + n + 1, cmp);
    for(int i = 1; i <= ans; i++)   //输出每个集合的人数
    {
        printf("%d", isRoot[i]);
        if(i < ans)
            printf(" ");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值