1107 Social Clusters(30 分)(c++)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​: h​i​​[1] h​i​​[2] ... h​i​​[K​i​​]

where K​i​​ (>0) is the number of hobbies, and h​i​​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

题目大意:根据爱好将人们划分为群落。

思路:本题有多种方法,DFS,BFS遍历即可,以及非常好用的并查集;以下为三种解法。

DFS遍历:

#include<iostream>
#include<vector>
#include<algorithm>
#include<queue>
#include<cstdio>
using namespace std;
int n,sum;
std::vector<int> visit;
std::vector<std::vector<int> > hobby(1005),people(1005);
std::vector<int> result;
void dfs(int root){
    visit[root]=1;
    sum++;
    for(int i=0;i<people[root].size();i++){
        int t=people[root][i];
        for(int j=0;j<hobby[t].size();j++){
            if(visit[hobby[t][j]]==0)
                dfs(hobby[t][j]);
            }
        }
}
int main(){
    scanf("%d",&n);
    visit.resize(n,0);
    for(int i=0;i<n;i++){
        int k;
        scanf("%d: ",&k);
        for(int j=0;j<k;j++){
            int temp;
            scanf("%d",&temp);
            people[i].push_back(temp);
            hobby[temp].push_back(i);
        }
    }
    for(int i=0;i<n;i++){
        sum=0;
        if(visit[i]==0){
            dfs(i);
            result.push_back(sum);
        }
    }
    sort(result.begin(), result.end());
    printf("%d\n",result.size());
    if(result.size()>0)
        printf("%d",result[result.size()-1]);
    for(int i=result.size()-2;i>=0;i--){
        printf(" %d",result[i]);
    }
	system("pause");
}

BFS遍历:

#include<iostream>
#include<vector>
#include<algorithm>
#include<queue>
#include<cstdio>
using namespace std;
int n;
std::vector<int> visit;
std::vector<std::vector<int> > hobby(1005),people(1005);
std::vector<int> result;
void bfs(int root){
    int sum=0;
    queue<int>q;
    q.push(root);
    visit[root]=1;
    while(!q.empty()){
        int front=q.front();
        for(int i=0;i<people[front].size();i++){
            int t=people[front][i];
            for(int j=0;j<hobby[t].size();j++){
                if(visit[hobby[t][j]]==0)
                    q.push(hobby[t][j]);
                visit[hobby[t][j]]=1;
            }
        }
        q.pop();
        sum++;
    }
    result.push_back(sum);
}
int main(){
    scanf("%d",&n);
    visit.resize(n,0);
    for(int i=0;i<n;i++){
        int k;
        scanf("%d: ",&k);
        for(int j=0;j<k;j++){
            int temp;
            scanf("%d",&temp);
            people[i].push_back(temp);
            hobby[temp].push_back(i);
        }
    }
    for(int i=0;i<n;i++){
        if(visit[i]==0){
            bfs(i);
        }
    }
    sort(result.begin(), result.end());
    printf("%d\n",result.size());
    if(result.size()>0)
        printf("%d",result[result.size()-1]);
    for(int i=result.size()-2;i>=0;i--){
        printf(" %d",result[i]);
    }
}

并查集:

#include <iostream>
#include <vector>
#include <set>
#include <algorithm>
using namespace std;
std::vector<int> hobbies[1005],father,cnt;
int n, k;
int findfather(int x){
    int a = x;
    while(x != father[x])
        x = father[x];
    while(a != x){
        int z = a;
        a = father[a];
        father[z] = a;
    }
    return x;
}
void join(int a, int b){
    int faa = findfather(a), fab = findfather(b);
    if(fab != faa)
        father[fab] = faa;
}
int main(){
    cin>>n;
    father.resize(n);
    cnt.resize(n,0);
    for(int i = 0; i < n; i++)
        father[i] = i;
    for(int i = 0; i < n; i++){
        scanf("%d:",&k);
        for(int j = 0; j < k; j++){
            int temp;
            scanf("%d",&temp);
            for(int u =0; u < hobbies[temp].size(); u++)
                join(i,hobbies[temp][u]);
            hobbies[temp].push_back(i);
        }
    }
    set<int>s;
    for(int i = 0; i < n; i++){
        int temp = findfather(i);
        s.insert(temp);
        cnt[temp]++;
    }
    sort(cnt.begin(), cnt.end(),greater<int>());
    printf("%d\n%d",s.size(),cnt[0]);
    for(int i = 1; i < s.size(); i++)
        printf(" %d",cnt[i]);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值