The Suspects POJ1611
传送门:http://poj.org/problem?id=1611
–004
Language:
The Suspects
Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 58756 Accepted: 27843
Description
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1
题目大意:有n个学生,编号从0到n-1,0号学生患有传染病,和他一组的人都将患病,问有多少人患病,输入n,m。接下来m行,每一行第一个数字k是该小组有k个学生,接下来k个学生编号。
思路:并查集,将学生分成几个大类,最后遍历,如果有学生的父节点和0的父节点相等,则他们为一类,都为患病。
AC代码
#include<cstdio>
#include<algorithm>
#include<iostream>
#include<set>
#include<queue>
#include<cmath>
using namespace std;
typedef long long ll;
int parent[30005];
int Rank[30005];
int Find(int x) //递归找父节点
{
if(x == parent[x])
return x;
return parent[x] = Find(parent[x]);
}
void un(int a, int b)
{
int x = Find(a);
int y = Find(b);
if(x == y)
return ;
else
{
if(Rank[x] > Rank[y])
parent[y] = x;
else
{
if(Rank[x] == Rank[y])
Rank[y]++;
parent[x] = y;
}
}
}
int main()
{
int n, m;
while(scanf("%d%d", &n, &m), n)
{
for(int i = 0; i <= n; i++) // 初始化
{
parent[i] = i;
Rank[i] = 0;
}
int s = 0;
while(m--)
{
int k, u, v;
scanf("%d%d", &k, &u);
k--;
while(k--)
{
scanf("%d", &v);
un(u, v);//将每组的每一个学生都和第一个学生进行union操作
}
}
for(int i = 0; i <= n; i++)
{
if(Find(i) == Find(0))
s++;
}
printf("%d\n", s);
}
return 0;
}