A是否等于B?

Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
Input
each test case contains two numbers A and B. 
Output
for each case, if A is equal to B, you should print "YES", or print "NO".
Sample Input
1 2
2 2
3 3
4 3
Sample Output
NO
YES
YES
NO

题目中要求是判断A和B是否相等,首先易错点

1.A,B不一定在int或long long 的精度范围。

2.A,B的形式可能不同,但是仍然可以相等,比如3.0和3;

3.小数点之后不一定要跟数字。3.   的形式是合法的小数。

代码:

#include <iostream>
using namespace std;
char a[100000], b[100000];
void fun(char *p)
{
	  int len = strlen(p);
	  char *p1 = p + len - 1;
	 if (strchr(p, '.'))
		 while (*p1 == '0') *p1-- = 0;
		 if (*p1 == '.') *p1 = 0;
 }
int main()
{
	while (cin >> a >> b)
	{
		fun(a), fun(b);
		if (strcmp(a, b) == 0)cout << "YES" << endl;
		else cout << "NO" << endl;
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值