还是畅通工程【Kruskal】

题目描述:原题链接

Description
某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。
Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。
Output
对每个测试用例,在1行里输出最小的公路总长度。
Sample Input
3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0
Sample Output
3
5

解法:Kruskal

思路:

运用到并查集和最小生成树,Kruskal模板题。

#include <stdio.h>
#include <iostream>
#include <algorithm>
using namespace std;
int father[101];
int findroot(int x)
{
	if(father[x] != x)
    father[x]=findroot(father[x]);
	return father[x];
}
struct edge{
	int a,b;
	int cost;
	bool operator < (const edge &A)const{
		return cost < A.cost;
	}
}e[6000];
int main()
{
	int n;
	while (scanf("%d",&n)&&n)
	{
		for (int i=0;i<(n-1)*n/2;i++)
			scanf("%d%d%d",&e[i].a,&e[i].b,&e[i].cost);
		sort(e,e+n*(n-1)/2);
		for (int i=1;i<=n;i++)
			father[i]=i;
		int ans=0;
		for (int i=0;i<n*(n-1)/2;i++)
		{
			int a=findroot(e[i].a);
			int b=findroot(e[i].b);
			if (a!=b)
			{
				father[a]=b;
				ans +=e[i].cost;
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值