A1078 Hashing

  1. 题目描述

The task of this problem is simple: insert a sequence of distinct(不同的) positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key %TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only)(正向二次探测法) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤104) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -
  1. 问题分析与伪代码

  1. 流程:表大小->填hash表->正向二次探测法解决冲突

  1. 表大小利用素数来解决

  1. 建立一个hashTable[]

  1. 没有填表的标记 -1,填表过的标记其数字即可(因为已经说是正数了)

  1. 利用正向二次探测法填表,若填表不成功,则输出-

3.代码编写

#include <iostream>
#include <algorithm>
#include <vector>
#include <math.h>
using namespace std;
int a[111];//二进制下,10^5用 111个数字来表示
bool IsPrime(int N)
{
    if(N<=1) return false;//注意边界条件
    int k=2;
    int boundry = sqrt(N);
    while(k<=boundry)  //求素数的判断范围有问题,需要尽可能的大
    {
        if(N%k==0)
            return false;
        k++;
    }
    return true;
}


int main()
{
    int Tsize=0,N;
    cin>>Tsize>>N;
    while(!IsPrime(Tsize))
    {
        Tsize++;
    }
    int hashTable[Tsize];
    for(int i=0;i<Tsize;i++)
    {
        hashTable[i] = -1;
    }
    int num =-1;
    int key = -1;
    for(int i=0;i<N;i++)
    {
        cin>>num;
        key = num%Tsize;
        if(hashTable[key]==-1)
        {
            hashTable[key] = num;
            i==N-1? cout<<key<<endl:cout<<key<<" ";

        }
        else
        {
            bool flag = false;
             for(int j=1;j<Tsize;j++)
             {
                 int pos = (num+j*j)%Tsize;
                 if(hashTable[pos]==-1)
                 {
                     hashTable[pos] = num;//注意找到后要进行赋值的
                     i==N-1? cout<<pos<<endl:cout<<pos<<" ";

                     flag = true;
                     break;
                 }
             }
            if(!flag)
            {
                i==N-1? cout<<"-"<<endl:cout<<"- ";

            }
        }

    }

    return 0;
}代码片

3.1 更简洁的代码

在这里插入代码片

4. 收获与思考

  • 双循环内 i,j一定要理清楚,尽量用不同的变量

  • 平方探测法要注意,是(num+i*i)%Tsize,i的最大值是Tsize-1

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值