A1060 Are They Equal

  1. 问题描述

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×105 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]...d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3
  1. 问题分析

  • 主要思想是 检查‘0’和‘.’来确定有效位数和尾数的值

  • 需要设置多个flag来进行筛选

  1. 代码

AC不了,有两个测试用例不能通过

#include <iostream>
#include <vector>
#include <string>
#include <map>
#include <algorithm>
#include <unordered_map>
#include <cstring>
#include <unordered_set>
using namespace std;
string science(string a,int N)
{

    string temp;
      int m1=0,m2=0;
      bool flag0 = false;
      bool flagfor = true;
      bool flagbeh= false;
      for(int i=0;i<a.size();i++)
      {
    // 需要判断两个 . 0
          if(a[i]!='0' && a[i]!='.' && flag0== false)
          {
//         说明第一个不为0 的数开始了
           flag0 = true;
          }
          if(a[i]=='.')
          {

              flagfor = false;
              flagbeh= true;
              continue;
          }
        if(flagbeh&&a[i]=='0')
          {
              m2++;
          }

          if(flag0)//后面的是有效数字了
          {
              temp+=a[i];//存储的是有效数字,但是不存储小数点

              if(flagfor)
              {
                  m1++;
              }

          }
      }
//    找到第一个非0位,数N位,作为小数部分,若不足则应当补0
//    根据小数点前的非0位数  m1 和小数点后的0的个数m2 来确定尾数m = m1-m2
      int m=m1-m2;
      string r ;
//      printf("0.%s*10^%d\n",temp.substr(0,N).c_str(),m);
        r+="0.";
        string former = temp.substr(0,N);
        r+=former;
        if(former.length()<N)
        {
            r+='0';
        }

      r+="*10^";
      r+= to_string(m);
    return r;
}
int main() {
    int N;
    string A,B;
    scanf("%d",&N);
    cin>>A>>B;
    string a = science(A,N);
    string b  = science(B,N);
    if(a==b)
    {
        printf("YES ");
        printf("%s\n",a.c_str());
    } else{
        printf("NO ");
        printf("%s %s\n",a.c_str(),b.c_str());
    }
    return 0;
}
  1. 思考与收获

  • 这个有点难

  • 必须要分析清楚问题再写代码,尽量找到解决问题的较简单的办法,或者较为直接的办法

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值