SDNU_ACM_ICPC_2020_Winter_Practice_2nd D拓扑排序

题目

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is
only possible if other tasks have already been executed.
Input
The input will consist of several instances of the problem. Each instance begins with a line containing
two integers, 1 ≤ n ≤ 100 and m. n is the number of tasks (numbered from 1 to n) and m is the
number of direct precedence relations between tasks. After this, there will be m lines with two integers
i and j, representing the fact that task i must be executed before task j.
An instance with n = m = 0 will finish the input.
Output
For each instance, print a line with n integers representing the tasks in a possible order of execution.
Sample Input
5 4
1 2
2 3
1 3
1 5
0 0
Sample Output
1 4 2 5 3

思路

拓扑排序

代码

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<string.h>
#include<vector>
#include<cmath>
#include <queue>
using namespace std;
typedef long long ll;
//const int inf = 0x3f3f3f3f;
int du[208];///入度
int t[207][207];///图
void topo(int n)
{
    int k;
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            if(du[j]==0)///入度为0的点
            {
                cout<<j;
                du[j]--;
                k=j;
                break;
            }
        }
        for(int j=1;j<=n;j++)
        {
            if(t[k][j]==1)
            {
                t[k][j]=0;///标记
                du[j]--;
            }
        }
        if(i<n)
            cout<<" ";
    }
}
int main()
{
    int n,m;
    while(cin>>n>>m&&(n!=0||m!=0))
    {

        for(int i=0;i<m;i++)
        {
            int u,v;
            cin>>u>>v;
            if(t[u][v]==0)
            {
                t[u][v]=1;
                du[v]++;
            }
        }
        topo(n);
        cout<<endl;
        memset(du,0,sizeof(du));
        memset(t,0,sizeof(t));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值