hdu_oj1102Constructing Roads

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 38214    Accepted Submission(s): 14102


 

Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 

 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 

 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 
 

 

Sample Input
 
3
0 990 692
990 0 179
692 179 0
1
1 2
 

 

Sample Output
 
179
 
 
这是一道图论求解 最小生成树变形的题目,应用kruskal算法和并查集就可以得到解决, 可能出现的问题就在于这个题目会给出这个生成树的分支,导致所有点的生成树并不一定是最小的,只是在给定生成树的某些分支下的最小生成树,我做这个题目的时候因为两个地方wa了好多次,一个是这个题目太坑了!!!没有给出多组样例的提示,另一个点就是在给出的分支(已经修建好的桥)往图上加边的时候也要用并查集进行检查!!!
下面附上ac代码
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <string>
#include <cstring>
using namespace std;
int a[110][110];
int parent[100001];
int ans;
struct Node
{
    int from,to,weight;
} b[100001];
bool cmp(Node a,Node b)
{
    return a.weight<b.weight;
}
int findroot(int i)
{
    if(parent[i]==i)
        return i;
    return parent[i]=findroot(parent[i]);
}
int main()
{
    int n;
    while(cin>>n)
    {
        ans=0;
        int j=0;
        for(int x=0; x<n; x++) //将数据存入结构体,此项还可以继续优化
            for(int y=0; y<n; y++)
            {
                cin>>b[j].weight;
                b[j].from=x;
                b[j].to=y;
                j++;
            }
        sort(b,b+j,cmp);

        for(int i=0; i<n; i++)
            parent[i]=i;
        int m;
        cin>>m;
        int temp1,temp2;
        for(int i=0; i<m; i++)
        {

            cin>>temp1>>temp2;
            temp1=findroot(temp1-1);//查找顶点
            temp2=findroot(temp2-1);//查找顶点
            if(temp1!=temp2)//判断是否连通
                parent[temp1]=parent[temp2];//没有连通,合并
        }

        for(int i=0; i<j; i++)
        {
            if(b[i].weight>0)
            {
                temp1=findroot(b[i].from);//查找顶点
                temp2=findroot(b[i].to);//查找顶点
                if(temp1!=temp2)//判断是否连通
                {
                    ans+=b[i].weight;//存储道路长度
                    parent[temp1]=parent[temp2]; //合并
                }
            }

        }
        cout<<ans<<endl;

    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值