dp专题 POJ-1742

题目
People in Silverland use coins.They have coins of value A1,A2,A3…An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn’t know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3…An and C1,C2,C3…Cn corresponding to the number of Tony’s coins of value A1,A2,A3…An then calculate how many prices(form 1 to m) Tony can pay use these coins.
Input
The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3…An,C1,C2,C3…Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.
Output
For each test case output the answer on a single line.
Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
Sample Output
8
4
题目大意
有n种金币价值分别为a[1],a[2],…,a[n],每种金币有数量b[1],b[2],…,b[n],问用这些金币能表示价值1~m中的几种?
解题思路
这是个多重背包可行性问题。
设f[i][j]表示用前i种数加和得到j时第i种数最多剩下多少个。
(不能加和标为-1)

当f[i-1][j]>=0时,f[i][j]=c[i]//如果前i-1种数家和已经能达到j了,那么用前i种数加和得到j是第i种数最多剩下c[i]个(只需第i-1个阶段比较即可,因为如果第k(k<i-1)个阶段的j状态能满足,则第i-1个阶段j状态也能瞒住)
当j-a[i]<0或f[i][j-a[i]]<=0时,f[i][j]=-1
其他情况 f[i][j]=f[i][j-a[i]]-1
最后如果f[n][j]>=0,这说明价值j可以表示
由于f[i][j]与第i-1个阶段与第i个阶段有关,可以把它写成一维。

#include <cstdio>
#include <cstring>
#define MAXN 101010
using namespace std;
int n,m;
int a[MAXN],c[MAXN],f[MAXN];
int main()
{
	while (true)
	{
	  scanf("%d%d",&n,&m);
	  if (n==0 && m==0) break;
	  for (int i=1;i<=n;i++)
	    scanf("%d",&a[i]);
	  for (int i=1;i<=n;i++)  
		scanf("%d",&c[i]);
	  memset(f,-1,sizeof(f));
	  f[0]=0;
	  for (int i=1;i<=n;i++)
	    for (int j=0;j<=m;j++)
		  if (f[j]>=0) f[j]=c[i]; 
		  else if (j-a[i]<0 || f[j-a[i]]<=0) f[j]=-1;
		  else f[j]=f[j-a[i]]-1;
	  int ans=0;
	  for (int i=1;i<=m;i++)
	    if (f[i]>=0) ans++;	  
      printf("%d\n",ans);		 
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值