PAT 1166 Summit

1166 Summit (25 分)

summit (峰会) is a meeting of heads of state or government. Arranging the rest areas for the summit is not a simple job. The ideal arrangement of one area is to invite those heads so that everyone is a direct friend of everyone.

Now given a set of tentative arrangements, your job is to tell the organizers whether or not each area is all set.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 200), the number of heads in the summit, and M, the number of friendship relations. Then M lines follow, each gives a pair of indices of the heads who are friends to each other. The heads are indexed from 1 to N.

Then there is another positive integer K (≤ 100), and K lines of tentative arrangement of rest areas follow, each first gives a positive number L (≤ N), then followed by a sequence of L distinct indices of the heads. All the numbers in a line are separated by a space.

Output Specification:

For each of the K areas, print in a line your advice in the following format:

  • if in this area everyone is a direct friend of everyone, and no friend is missing (that is, no one else is a direct friend of everyone in this area), print Area X is OK..

  • if in this area everyone is a direct friend of everyone, yet there are some other heads who may also be invited without breaking the ideal arrangement, print Area X may invite more people, such as H. where H is the smallest index of the head who may be invited.

  • if in this area the arrangement is not an ideal one, then print Area X needs help. so the host can provide some special service to help the heads get to know each other.

Here X is the index of an area, starting from 1 to K.

思路

共三种情况:

1.不为全连接图。双重for循环判断是否全连接

2.全连接且可以加入节点:从小到大遍历可以加入的节点,对可以加入的节点判断与现有节点是否有边

3.全连接且无法加入别的节点:双重for循环判断是否全连接,且所有节点经判断均不可加入

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
2 4 6
3 3 2 1

Sample Output:

Area 1 is OK.
Area 2 is OK.
Area 3 is OK.
Area 4 is OK.
Area 5 may invite more people, such as 3.
Area 6 needs help.
#include<bits/stdc++.h>
using namespace std;
int jz[205][205];
int z[205];
int main()
{
	int n, m; cin >> n >> m;
	for (int i = 1; i <= m; ++i)
	{
		int x, y; cin >> x >> y;
		jz[x][y] = 1;
		jz[y][x] = 1;
	}
	int k; cin >> k;
	for (int i = 1; i <= k; ++i)
	{
		int q; cin >> q;
		for (int j = 1; j <= q; ++j)
		{
			cin >> z[j];
		}
		int f = 0;
		for (int j = 1; j <= q; ++j)
		{
			for (int l = 1; l <= q; ++l)
			{
				if (j == l)continue;
				if (jz[z[j]][z[l]] == 0)
				{
					f = 1;
					break;
				}
			}
			if (f == 1)
			{
				break;
			}
		}
		if (f == 1)
		{
			printf("Area %d needs help.\n", i);
		}
		else
		{
			int fl = 0;
			for (int j = 1; j <= n; ++j)
			{
				fl = 0;
				for (int l = 1; l <= q; ++l)
				{
					if (j == z[l]||jz[j][z[l]]==0)
					{
						fl = 1;
						break;
					}
				}
				if (fl == 1)continue;
				else
				{
					printf("Area %d may invite more people, such as %d.\n", i, j);
					fl = 2;
					break;

				}
			}
			if (fl != 2)
			{
				printf("Area %d is OK.\n", i);
			}
		}
	}

}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值