胜利大逃亡 HDU - 1253

胜利大逃亡 HDU - 1253

Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个ABC的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.

Input

输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块…),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入.

Output

对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.

Sample Input

1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0

Sample Output

11

Sponsor

题记

bfs求最短路的模板题

AC的C++代码如下:

#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
const int N = 55;
int k;
int a, b, c, t;
int dist[N][N][N];          //存储时间
int g[N][N][N];             //存储地图
int dx[6] = { 0, 0, 0, 0, 1, -1 };         //方向向量
int dy[6] = { 0, 0, 1, -1, 0, 0 };
int dz[6] = { 1, -1, 0, 0, 0, 0 };
struct node
{
	int x;
	int y;
	int z;
};


int bfs(node start, node end)
{
	queue<node> q;
	q.push(start);
	memset(dist, -1, sizeof dist);            //所有的方格设置为没被搜过,即-1
	dist[1][1][1] = 0;  
	node t;
	while (q.size())
	{
		t = q.front();
		q.pop();

		for (int i = 0; i < 6; i++)
		{
			int tx = dx[i] + t.x, ty = dy[i] + t.y, tz = dz[i] + t.z;
			if (tx < 1 || tx > a || ty < 1 || ty > b || tz < 1 || tz > c) continue; //越界
			if (g[tx][ty][tz]) continue;                                            //障碍
			if (dist[tx][ty][tz] != -1) continue;                                   //已经搜过

			dist[tx][ty][tz] = dist[t.x][t.y][t.z] + 1;
			if (tx == end.x && ty == end.y && tz == end.z) return dist[tx][ty][tz]; //到达终点
			q.push({ tx, ty, tz });
		}
	}
	return -1;
}

int main()
{
	scanf("%d", &k);
	while (k--)
	{
		scanf("%d%d%d%d", &a, &b, &c, &t);
		for (int i = 1; i <= a; i++)
			for (int j = 1; j <= b; j++)
				for (int k = 1; k <= c; k++)
					scanf("%d", &g[i][j][k]);    
		node start = { 1,1,1 }, end = { a, b, c };
		if (bfs(start, end) <= t && bfs(start, end) != -1) cout << bfs(start, end) << endl;     //如果在t时间内,并且有可移动的路径
		else cout << -1 << endl;
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值