Team Formation(异或+位移+并)

Team Formation

For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team from N students of his university.

Edward knows the skill level of each student. He has found that if two students with skill level A and B form a team, the skill level of the team will be A ⊕ B, where ⊕ means bitwise exclusive or. A team will play well if and only if the skill level of the team is greater than the skill level of each team member (i.e. A ⊕ B > max{A, B}).

Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different team member.

Input
There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line contains N positive integers separated by spaces. The ith integer denotes the skill level of ith student. Every integer will not exceed 109.

Output
For each case, print the answer in one line.

Sample Input
2
3
1 2 3
5
1 2 3 4 5
Sample Output
1
6

思路

  • 异或就是 1^0=1 , 1^1=0 , 0^0=0, 因此只有0和1异或才能变的更大
  • 因此我们要寻找 某数字0和1的位置
  • 假设 1(1),2(10),3(11),1^2 = (1^10)=11 (其实就是1和0异或,位数相同) 因此我们存一下每一个数的首位的位置,让他与另外的数的0位异或。
#include<bits/stdc++.h>
using namespace std;
const int MAX=1e6+10;
int num,t,x,n;
int sum[MAX],ans,a[MAX];
int main(){
	cin >> t;
	while(t--){
		ans=0;
		memset(sum,0,sizeof(sum));
		scanf("%d",&n);
		for(int i=1;i<=n;i++){
			scanf("%d",&a[i]);
			x=a[i];
			num=0;
			while(x){
				num++;
				x>>=1;
			}
			sum[num]++;  //存储首位的位置在同一位数的数量
		}
		for(int i=1;i<=n;i++){
			int x=a[i];
			num=0;
			while(x){
			num++;
			if(!(x&1)){  //x的0位在第一位的时候
				ans+=sum[num]; //此时答案加上1在同一位置时的数量
			}
			x>>=1;
			}
		}
		cout << ans << endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

杂货店的阿猿

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值