Team Formation(思维)

Team Formation

Time Limit: 3 Seconds       Memory Limit: 131072 KB

For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team from N students of his university.

Edward knows the skill level of each student. He has found that if two students with skill level A and B form a team, the skill level of the team will be A ⊕ B, where ⊕ means bitwise exclusive or. A team will play well if and only if the skill level of the team is greater than the skill level of each team member (i.e. A ⊕ B > max{A, B}).

Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different team member.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line contains N positive integers separated by spaces. The ith integer denotes the skill level of ith student. Every integer will not exceed 109.

Output

For each case, print the answer in one line.

Sample Input
2
3
1 2 3
5
1 2 3 4 5
Sample Output
1
6

Author: LIN, Xi
Source: The 12th Zhejiang Provincial Collegiate Programming Contest

题解:

N个球员,每个球员有一个水平值,现在要组队,每个队两个人,这个队的水平就是这两个人水平的异或,这个队能打好代表这个异或值大于人一个队员;问多少种组队方法;两个队不同即为任意一个队员不同;燕帅给提供的思路,就是记录每个人最高位出现的位置,对于每个人,只需找比这个人小的水平与其异或大于自己的个数和就好了;

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstring>
#include<algorithm>
const int MAXN = 100010;
int a[MAXN], num[100];
typedef long long LL;
int geth(int x){
    int i;
    for(i = 0;;i++){
        if((1 << i) > x)break;
    }
    return i;
}
int main(){
    int T, N;
    scanf("%d", &T);
    while(T--){
        memset(num, 0, sizeof(num));
        scanf("%d", &N);
        for(int i = 0; i < N; i++){
            scanf("%d", a + i);
            num[geth(a[i])]++;
        }
        LL ans = 0;
        //for(int i = 0; i < 10; i++)printf("%d ", num[i]);puts("");
        for(int i = 0; i < N; i++){
            if(a[i] > 0 && a[i] % 2 == 0)ans += num[0];
            for(int j = 1; (1 << (j - 1)) < a[i]; j++){
                if((a[i] ^ (1 << (j - 1))) > a[i])ans += num[j];
            //    printf("i = %d %d %d\n", a[i], 1 << (j - 1), a[i] ^ (1 << (j - 1)));
            }
            //printf("%d ", ans);
        }//puts("");
        printf("%lld\n", ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值