B - Team Formation (异或)

For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team from N students of his university.

Edward knows the skill level of each student. He has found that if two students with skill level A and B form a team, the skill level of the team will be A ⊕ B, where ⊕ means bitwise exclusive or. A team will play well if and only if the skill level of the team is greater than the skill level of each team member (i.e. A ⊕ B > max{A, B}).

Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different team member.

Input

There are multiple test cases. The first line of input contains an integer Tindicating the number of test cases. For each test case:

The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line contains N positive integers separated by spaces. The ithinteger denotes the skill level of ith student. Every integer will not exceed 109.

Output

For each case, print the answer in one line.

Sample Input

2
3
1 2 3
5
1 2 3 4 5

Sample Output

1
6

题意:任意两个数进行异或运算,如果得到的值比这两个数的最大值还要大,answer就加1;

题解:两个数a和b进行异或运算(a<b),a的最高位肯定为1,那么看b的对应位,如果b所对应的位为0,那么异或成功,否则失败。那么我们首先将数组从大到小排序,对应每一个数:首先遍历其位的情况(0or1),如果该位为0,就加上在这个数之前最高位为1的情况。每一重循环之后要将最高位数组加1~

#include<bits/stdc++.h>
using namespace std;
const int maxn=100010;
int cnt[100],a[maxn];
int n,ans;
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        ans=0;
        memset(cnt,0,sizeof(cnt));
        cin>>n;
        for(int i=1;i<=n;i++)
            cin>>a[i];
        sort(a+1,a+1+n);//从小到大遍历以备遍历
        for(int i=1;i<=n;i++)
        {
            int top=0;
            while(a[i])//记录这个数和该数之前的任一个数组合的情况
            {
                top++;
                int k=a[i]&1;//取最后一位
                if(k==0)//如果这位为0,加上这个数之前的最高位为1的个数
                    ans+=cnt[top];
                a[i]/=2;
            }
            cnt[top]++;//更新最高位为1的个数
        }
        cout<<ans<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值