杭电科大ACM:An Easy Task

An Easy Task

Problem Description

Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?
Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.
Note: if year Y is a leap year, then the 1st leap year is year Y.

伊格内修斯出生在闰年,所以他想知道什么时候可以举办他的生日派对。 你能告诉他吗?
给定一个表示起始年份的正整数 Y 和一个正整数 N,你的任务是从 Y 年中分辨出第 N 个闰年。
注意:如果 Y 年是闰年,则第一个闰年是 Y 年。

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains two positive integers Y and N(1<=N<=10000)
输入包含几个测试用例。 输入的第一行是一个整数 T,它是测试用例的数量。 T测试用例如下。
每个测试用例包含两个正整数 Y 和 N(1<=N<=10000)

Output

For each test case, you should output the Nth leap year from year Y.
对于每个测试用例,您应该输出 Y 年的第 N 个闰年。

Sample Input

3
2005 25
1855 12
2004 10000

Sample Output

2108
1904
43236

We call year Y a leap year only if (Y%40 && Y%100!=0) or Y%4000.
仅当 (Y%40 && Y%100!=0) 或 Y%4000 时,我们才称 Y 年为闰年。
在这里插入图片描述

#include<stdio.h>
int main(){
	int T,Y,N;
	int i,result=0;
	scanf("%d",&T);
	while(T--){
		scanf("%d %d",&Y,&N);
		if(1<=N<=10000){
		for(i=Y;result<N;i++){
			if((i%4==0 && i%100!=0) || i%400==0){
				result++;
			}
			if(result==N){
				printf("%d\n",i); 
				result=0;
				break; 
			}
			
		}
		}
		else
			continue; 

	}
	return 0; 
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值