PAT A1016 Phone Bills (25分)

1016 Phone Bills (25分)
A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:
Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (MM:dd:HH:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:
For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:HH:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line
Sample Output:
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int toll[24];

struct Person{
	char name[22];
	int month,dd,hh,mm;
	bool status;
};
bool cmp(Person p1, Person p2){
	if(strcmp(p1.name,p2.name)!=0) return strcmp(p1.name,p2.name)<0;
	if(p1.dd != p2.dd) return p1.dd < p2.dd;
	if(p1.hh != p2.hh) return p1.hh < p2.hh;
	if(p1.mm != p2.mm) return p1.mm < p2.mm;
}
void cal(Person on, Person off, int &time, int &money){
	while(on.dd!=off.dd || on.hh!=off.hh || on.mm!=off.mm){
		on.mm++;
		time++;
		money += toll[on.hh];
		if(on.mm == 60){
			on.hh++;
			on.mm = 0;
		}
		if(on.hh == 24){
			on.dd++;
			on.hh = 0;
		}
	}
	
}
int main(){
	
	for(int i=0; i<24; i++){
		scanf("%d", &toll[i]);
	}
	
	int n;
	scanf("%d", &n);
	
	Person p[n];
	char temp_c[10];
	for(int i=0; i<n; i++){
		scanf("%s %d:%d:%d:%d %s", &p[i].name, &p[i].month, &p[i].dd, &p[i].hh, &p[i].mm, &temp_c);
		if(strcmp(temp_c,"on-line")==0){
			p[i].status = 1;
		}else if(strcmp(temp_c,"off-line")==0){
			p[i].status = 0;
		}
	}
	
	sort(p, p+n, cmp);
	
	int on = 0, off, next;
	while(on < n){
		int needPrint = 0;
		next = on;
		
		while(next<n && strcmp(p[next].name,p[on].name)==0){
			if(needPrint==0 && p[next].status==1){
				needPrint = 1;
			}else if(needPrint==1 && p[next].status==0){
				needPrint = 2;
			}
			next++;
		}
		if(needPrint!=2){
			on = next;
			continue;
		}
		
		int all_money = 0;
		printf("%s %02d\n", p[on].name, p[on].month);
		
		while(on < next){
			while(on<next-1 && !(p[on].status==1 && p[on+1].status==0)){
				on++;
			}
			
			off = on + 1;
			if(off == next){
				on = off;
				break;
			}
			
			printf("%02d:%02d:%02d ", p[on].dd, p[on].hh, p[on].mm);
			printf("%02d:%02d:%02d ", p[off].dd, p[off].hh, p[off].mm);
			
			int time = 0; int money = 0;
			cal(p[on],p[off],time,money);
			all_money += money;
			printf("%d $%.2f\n", time, money/100.0);
			on = off+1;
		}
		printf("Total amount: $%.2f\n", all_money/100.0);
	}
	return 0;
}

这题应该是我刷算法笔记以来遇到过的最难的一道题目了,前前后后大概花了我5个小时来研究。我自己先独自花了大概2个小时来做,只对了测试点1拿了15分。花了1小时来找错,但是因为写的时候代码逻辑太混乱了,找错把自己也找晕了,后来没办法只能看书了。这题最难的一块就是控制名字的输出了,如果有多条记录只能输出一次名字,而且如果记录只有on而没有对应的off还不能输出名字。又花了2小时时间来分析书上的代码,并自己动手完整的敲了两遍,感觉这种题目细节太难把控了,一不小心就会满盘皆错。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值