并查集——Wireless Network

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:

  1. “O p” (1 <= p <= N), which means repairing computer p.
  2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.
Output
For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL
SUCCESS

题目思路:本题的条件是当两个电脑修好并且距离小于d时是成功的,两个条件缺一不可。所以就需要有一个数组来记录电脑是否修好。
在判断时,也必须判断p和q的父本是否相同。

ac代码
#include<stdio.h>
#include<string.h>
int pre[300005],rep[300005];
int find(int x)
{
if(pre[x]x) return x;
return pre[x]=find(pre[x]);
}
void join(int x,int y)
{
int fx=find(x);
int fy=find(y);
if(fx!=fy)
pre[fy]=fx;
}
//以上为并查集模板
int main()
{
int n,d,l;
char ch[10];
int x[300005],y[300005];
int p,q;
while(scanf("%d%d",&n,&d)!=EOF)
{
memset(rep,0,sizeof(rep)); //初始化数组
for(int i=1;i<=n;i++)
scanf("%d%d",&x[i],&y[i]);
for(int i=1;i<=n;i++) //初始化使每个电脑的父本都为自己
pre[i]=i;
while(~scanf("%s",&ch[0]))
{
if(ch[0]
‘O’) //判断为修电脑时
{
scanf("%d",&p);
rep[p]=1;
for(int i=1;i<=n;i++)
{
l=(x[p]-x[i])(x[p]-x[i])+(y[p]-y[i])(y[p]-y[i]);
if(l<=d*d&&rep[i]) //当距离小于d已经两个电脑都修好时把他们连在一起
join(p,i);
}
}
else if(ch[0]==‘S’)
{
scanf("%d%d",&p,&q);
if(find§==find(q)&&rep[p]&&rep[q])
printf(“SUCCESS\n”);
else
printf(“FAIL\n”);
}
}
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值