AcWing 852. spfa判断负环

问题描述:

给定一个 n n n个点 m m m 条边的有向图,图中可能存在重边和自环, 边权可能为负数

请你判断图中是否存在负权回路。

输入格式:

第一行包含整数 n n n , m m m

接下来 m m m 行每行包含三个整数 x x x, y y y, z z z,表示存在一条从点 x x x 到点 y y y 的有向边,边长为 z z z

输出格式:

如果图中存在负权回路,则输出“Yes”,否则输出“No”。

数据范围

1 ≤ n ≤ 2000 , 1≤n≤2000, 1n2000,
1 ≤ m ≤ 10000 , 1≤m≤10000, 1m10000,
图中涉及边长绝对值均不超过 10000 10000 10000

输入样例:

3 3
1 2 -1
2 3 4
3 1 -4

输出样例:

Yes

时间复杂度 O ( m n ) O(mn) O(mn)

#include <iostream>
#include <queue>
#include <cstring>
#include <algorithm>

using namespace std;

const int N = 1e5 + 10;

int h[N], w[N], e[N], ne[N], idx;
int dist[N], cnt[N];
bool st[N];
int n, m;

void add(int a, int b, int c)
{
    e[idx] = b, w[idx] = c, ne[idx] = h[a], h[a] = idx ++;
}

bool spfa()
{
    
    queue<int> q;
    
    for (int i = 1; i <= n; i ++ )
    {
        st[i] = true;
        q.push(i);
    }
    
    while (!q.empty())
    {
        int t = q.front();
        q.pop();
        
        st[t] = false;
        //更新t的所有临边
        for (int i = h[t]; i != -1; i = ne[i])
        {
            int j = e[i]; //j来表示这个点
            if (dist[j] > dist[t] + w[i])
            {
                dist[j] = dist[t] + w[i];
                cnt[j] = cnt[t] + 1; 
                
                if (cnt[j] >= n) return true;
                if (!st[j])
                {
                    q.push(j);
                    st[j] = true;
                }
            }
        }
    }
    
    return false;
}

int main()
{
    cin >> n >> m;
    
    memset(h, -1, sizeof h);
    for (int i = 0; i < m; i ++ )
    {
        int a, b, c;
        cin >> a >> b >> c;
        add(a, b, c);
    }
    
    if (spfa()) puts("Yes");
    else puts("No");
    
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值