POJ-2632:Crashing Robots(C++实现详细代码)

传送门
Description

In a modernized warehouse, robots are used to fetch the goods. Careful
planning is needed to ensure that the robots reach their destinations
without crashing into each other. Of course, all warehouses are
rectangular, and all robots occupy a circular floor space with a
diameter of 1 meter. Assume there are N robots, numbered from 1
through N. You will get to know the position and orientation of each
robot, and all the instructions, which are carefully (and mindlessly)
followed by the robots. Instructions are processed in the order they
come. No two robots move simultaneously; a robot always completes its
move before the next one starts moving. A robot crashes with a wall if
it attempts to move outside the area of the warehouse, and two robots
crash with each other if they ever try to occupy the same spot.

Input

The first line of input is K, the number of test cases. Each test case
starts with one line consisting of two integers, 1 <= A, B <= 100,
giving the size of the warehouse in meters. A is the length in the
EW-direction, and B in the NS-direction. The second line contains two
integers, 1 <= N, M <= 100, denoting the numbers of robots and
instructions respectively. Then follow N lines with two integers, 1 <=
Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the
starting position and direction of each robot, in order from 1 through
N. No two robots start at the same position.

Figure 1: The starting positions of the robots in the sample warehouse

Finally there are M lines, giving the instructions in sequential
order. An instruction has the following format: < robot #> < action> <
repeat> Where is one of L: turn left 90 degrees, R: turn right 90
degrees, or F: move forward one meter,

and 1 <= < repeat> <= 100 is the number of times the robot should
perform this single move.
在这里插入图片描述

Output

Output one line for each test case: Robot i crashes into the wall, if
robot i crashes into a wall. (A robot crashes into a wall if Xi = 0,
Xi = A + 1, Yi = 0 or Yi = B + 1.) Robot i crashes into robot j, if
robots i and j crash, and i is the moving robot. OK, if no crashing
occurs.

Only the first crash is to be reported.

Sample Input

4
5 4
2 2
1 1 E
5 4 W
1 F 7
2 F 7
5 4
2 4
1 1 E
5 4 W
1 F 3
2 F 1
1 L 1
1 F 3
5 4
2 2
1 1 E
5 4 W
1 L 96
1 F 2
5 4
2 3
1 1 E
5 4 W
1 F 4
1 L 1
1 F 20

Sample Output

Robot 1 crashes into the wall
Robot 1 crashes into robot 2
OK
Robot 1 crashes into robot 2
#include<iostream>
#include<stdio.h>
#include<string>
#include<vector>
#include<queue>
#include<algorithm>
using namespace std;
bool judge = false;
int rect[101][101];
int A, B;//边界
struct robot
{
	int x, y;
	char direct;
}rob[101];
struct intstruction
{
	int ID;
	char act;
	int repeat;
}ist[101];
void F(int ID, int repeat)//移动
{
	if (rob[ID].direct == 'E')
	{
		for (int i = 1; i <= repeat; i++)
		{
			if (rob[ID].x + i > A)
			{
				judge = true;
				cout << "Robot " << ID << " crashes into the wall" << endl;
				return;
			}
			if (rect[rob[ID].y][rob[ID].x + i] != 0)
			{
				judge = true;
				cout << "Robot " << ID << " crashes into robot " << rect[rob[ID].y][rob[ID].x + i] << endl;
				return;
			}
		}
		rect[rob[ID].y][rob[ID].x] = 0;
		rob[ID].x += repeat;
		rect[rob[ID].y][rob[ID].x] = ID;
	}
	else if (rob[ID].direct == 'W')
	{
		for (int i = 1; i <= repeat; i++)
		{
			if (rob[ID].x - i < 1)
			{
				judge = true;
				cout << "Robot " << ID << " crashes into the wall" << endl;
				return;
			}
			if (rect[rob[ID].y][rob[ID].x - i] != 0)
			{
				judge = true;
				cout << "Robot " << ID << " crashes into robot " << rect[rob[ID].y][rob[ID].x - i] << endl;
				return;
			}
		}
		rect[rob[ID].y][rob[ID].x] = 0;
		rob[ID].x -= repeat;
		rect[rob[ID].y][rob[ID].x] = ID;
	}
	else if (rob[ID].direct == 'N')
	{
		for (int i = 1; i <= repeat; i++)
		{
			if (rob[ID].y + i > B)
			{
				judge = true;
				cout << "Robot " << ID << " crashes into the wall" << endl;
				return;
			}
			if (rect[rob[ID].y + i][rob[ID].x] != 0)
			{
				judge = true;
				cout << "Robot " << ID << " crashes into robot " << rect[rob[ID].y + i][rob[ID].x] << endl;
				return;
			}
		}
		rect[rob[ID].y][rob[ID].x] = 0;
		rob[ID].y += repeat;
		rect[rob[ID].y][rob[ID].x] = ID;
	}
	else
	{
		for (int i = 1; i <= repeat; i++)
		{
			if (rob[ID].y - i < 1)
			{
				judge = true;
				cout << "Robot " << ID << " crashes into the wall" << endl;
				return;
			}
			if (rect[rob[ID].y - i][rob[ID].x] != 0)
			{
				judge = true;
				cout << "Robot " << ID << " crashes into robot " << rect[rob[ID].y - i][rob[ID].x] << endl;
				return;
			}
		}
		rect[rob[ID].y][rob[ID].x] = 0;
		rob[ID].y -= repeat;
		rect[rob[ID].y][rob[ID].x] = ID;
	}
}
void L(int ID, int repeat)//左转
{
	repeat %= 4;
	if (repeat == 1)
	{
		if (rob[ID].direct == 'E')
			rob[ID].direct = 'N';
		else if (rob[ID].direct == 'S')
			rob[ID].direct = 'E';
		else if (rob[ID].direct == 'W')
			rob[ID].direct = 'S';
		else
			rob[ID].direct = 'W';
	}
	else if (repeat == 2)
	{
		if (rob[ID].direct == 'E')
			rob[ID].direct = 'W';
		else if (rob[ID].direct == 'S')
			rob[ID].direct = 'N';
		else if (rob[ID].direct == 'W')
			rob[ID].direct = 'E';
		else
			rob[ID].direct = 'S';
	}
	else if (repeat == 3)
	{
		if (rob[ID].direct == 'E')
			rob[ID].direct = 'S';
		else if (rob[ID].direct == 'S')
			rob[ID].direct = 'W';
		else if (rob[ID].direct == 'W')
			rob[ID].direct = 'N';
		else
			rob[ID].direct = 'E';
	}
}
void R(int ID, int repeat)//右转
{
	repeat %= 4;
	if (repeat == 1)
	{
		if (rob[ID].direct == 'E')
			rob[ID].direct = 'S';
		else if (rob[ID].direct == 'S')
			rob[ID].direct = 'W';
		else if (rob[ID].direct == 'W')
			rob[ID].direct = 'N';
		else
			rob[ID].direct = 'E';
	}
	else if (repeat == 2)
	{
		if (rob[ID].direct == 'E')
			rob[ID].direct = 'W';
		else if (rob[ID].direct == 'S')
			rob[ID].direct = 'N';
		else if (rob[ID].direct == 'W')
			rob[ID].direct = 'E';
		else
			rob[ID].direct = 'S';
	}
	else if (repeat == 3)
	{
		if (rob[ID].direct == 'E')
			rob[ID].direct = 'N';
		else if (rob[ID].direct == 'S')
			rob[ID].direct = 'E';
		else if (rob[ID].direct == 'W')
			rob[ID].direct = 'S';
		else
			rob[ID].direct = 'W';
	}
}
int main()
{
	int K;
	scanf("%d",&K);
	while (K--)
	{
		judge = false;
		scanf("%d%d",&A, &B);
		memset(rect, 0, sizeof(rect));
		int N, M;
		scanf("%d%d",&N, &M);
		for (int i = 1; i <= N; i++)
		{
			cin >> rob[i].x >> rob[i].y >> rob[i].direct;
			rect[rob[i].y][rob[i].x] = i;//标志有机器人的位置
		}
		for (int i = 1; i <= M; i++)
			cin >> ist[i].ID >> ist[i].act >> ist[i].repeat;
		for (int i = 1; i <= M; i++)
		{
			if (ist[i].act == 'F')
				F(ist[i].ID, ist[i].repeat);
			else if (ist[i].act == 'L')
				L(ist[i].ID, ist[i].repeat);
			else
				R(ist[i].ID, ist[i].repeat);
			if (judge)
				break;
		}
		if (!judge)
			cout << "OK" << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

艺千秋录

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值