Catch That Caw

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 * X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

本题寻找最短的步数,所以可以用BFS算法实现,每次对各个操作进行一次搜索,并存下当前位置

#include<iostream>
#include<cstdio>
#include<queue>
#include<algorithm>
using namespace std;
const int MAXN = 200005;
int vis[MAXN];//标记有没有达到过
int dx[] = { 0,0,1,-1 };
int dy[] = { 1,-1,0,0 };
const int INF = 1e9;
int  n, k;
struct node {
	int x, step;
};
queue<node> q;
void bfs() {
	int X, Step;
	while (!q.empty()) {
		node ND2 = q.front();
		q.pop();
		X = ND2.x;
		Step = ND2.step;
		if (X == k) {
			cout << Step << endl;
			return;
		}
		if (X >= 1 && vis[X - 1] == 0) {
			node ND3;
			vis[X - 1] = 1;
			ND3.x = X - 1;
			ND3.step = Step + 1;
			q.push(ND3);
		}
		if (X <= k && vis[X + 1] == 0) {
			node ND3;
			vis[X + 1] = 1;
			ND3.x = X + 1;
			ND3.step = Step + 1;
			q.push(ND3);
		}
		if (X <= k && vis[X * 2] == 0) {
			node ND3;
			vis[X * 2] = 1;
			ND3.x = X * 2;
			ND3.step = Step + 1;
			q.push(ND3);
		}

	}
}
void solve() {
	while (~scanf("%d%d", &n, &k)) {
		while (!q.empty())
			q.pop();//清空
		memset(vis, 0, sizeof vis);
		vis[n] = 1;//标记初始位置n
		node ND1;
		ND1.x = n;
		ND1.step = 0;
		q.push(ND1);
		bfs();
	}
}
 int main() {
	//int _;
	//cin >> _;
	//while (_--) {
		solve();
	//{
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值