1490:A Knight‘s Journey (DFS 输出路径问题 板子)

31 篇文章 0 订阅
30 篇文章 0 订阅

描述
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
输入
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
输出
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
样例输入
3
1 1
2 3
4 3
样例输出
Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

题目链接
题目大意:
马从(1,1)出发,走日(象棋的马),是否能把图走一遍,每个点走一遍,能输出路径(字典序最小的路径。图的Y轴为A-Z,X 轴为1-26,点的形式为A1, 即YX。
思路: DFS板子。
代码:

#include<cstdlib>
#include<iostream>
#include<cstring>

using namespace std;
int minn;
int ans;
int nest[8][2]={{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};
const int N=29;
int book[N][N];
struct note
{
    int x;
    int y;
};
int q,p;
struct note que[N*N];
int tail,head;
int flag=0;
int area;
void dfs(int x,int y,int step)
{
    if(flag==1)
        return;
    que[step].x=x;
    que[step].y=y;
    if(step==area)
    {
        flag=1;
        return;
    }
    int tx,ty;
    for(int k=0; k<8; k++)
    {
        tx=nest[k][0]+x;
        ty=nest[k][1]+y;
        if(tx>=1 && tx<=q && ty>=1 && ty<=p )
        {
            if(book[tx][ty]==0)
            {
                book[tx][ty]=1;
                dfs(tx,ty,step+1);
                book[tx][ty]=0;
            }
        }
    }



}

int main()
{
    int test;
    int k=0;
    scanf("%d",&test);
    while(test--)
    {
        k++;
        scanf("%d %d",&q,&p);
        area=q*p;
        flag=0;
        memset(book,0,sizeof(book));
        book[1][1]=1;
        dfs(1,1,1);
        printf("Scenario #%d:\n",k);
        if(flag==1)
        {
            for(int i=1; i<=area; i++)
            {
                printf("%c%d",que[i].y+'A'-1,que[i].x);
            }
            printf("\n");
        }
        else
        {
            printf("impossible\n");
        }
        printf("\n");

    }


    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值