River Hopscotch (二分法)

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).
To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.
Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N).
FJ wants to know exactly how much he can increase the shortest distance before he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.
Input
Line 1: Three space-separated integers:
L, N, and M

Lines 2…
N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.
Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks
Sample Input
25 5 2
2
14
11
21
17
Sample Output
4
题意:有 l 宽的河流,中放有 n 块石头,想在需要移动一些石头,使石头之间的距离变大,且最多只能移动 m 块,然后需要找出移动之后,相邻石头之间最短距离的最大值
解题思路:首先这又是一个关于最什么最什么的问题(最短距离的最大值),所以采用二分法来解决问题,首先我们可以看出二分搜索的最初范围,也就是low=0,high=河宽,然后再来找mid,并根据情况缩小范围,最终找出最短距离的最大值;
解题步骤
1)首先注意有多组测试样列,所以得用scanf("%d%d%d",&l,&n,&m)!=EOF,或~scanf("%d%d%d",&l,&n,&m)作为while输入的条件;
2)找出初始的low和high的值,也就是二分查找的范围;
3)用二分查找,找出最短距离的最大值;注意:满足要求的并不一定就是所得的目标;

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn=50005;
int a[maxn];
int l,n,m;
int main()
{
    while(scanf("%d%d%d",&l,&n,&m)!=EOF)
        {
            int low=0,high=l,mid;
            for(int i=0;i<n;i++)
                scanf("%d",&a[i]);
            sort(a,a+n);
            while(low<=high)
                {
                    mid=(low+high)/2;
                    int num=0,an=0;
                    for(int i=0;i<n;i++)
                        {
                            if(a[i]-an>=mid)
                                an=a[i];
                            else num++;
                        }
                    if(num>m) high=mid-1;
                    else low=mid+1;
                }
            printf("%d\n",high);
        }
    return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值