W1——Aggressive cows Problem

问题描述

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000).
His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

Line 1: Two space-separated integers: N and C
Lines 2…N+1: Line i+1 contains an integer stall location, xi

Output

Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS:
FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.
Huge input data,scanf is recommended.

Code

/*
 * @Description: Aggressive cows
 * @version: 
 * @Author: 
 * @Date: 2021-03-30 22:06:29
 * @LastEditors: Please set LastEditors
 * @LastEditTime: 2021-03-31 15:08:08
 */
// 算法:二分查找,来源于网络
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
int n, c;
vector<long long> stall;

bool check(int mid)
{
    int ans = 1;
    // 在最小位置放一只
    int temp = stall[0];
    for (int i = 1; i < n; i++)
    {
        if (stall[i] - temp >= mid)
        {
            // 距离大于等于mid则放一只牛
            ans++;
            temp = stall[i];
            if (ans >= c)
                // 如果能放下c只牛则返回true,在右半部分继续查找
                return true;
        }
    }
    // 否则在左边查找
    return false;
}
int main()
{
    scanf("%d %d", &n, &c);
    for (int i = 0; i < n; i++)
    {
        long long num;
        scanf("%lld", &num);
        stall.push_back(num);
    }
    sort(stall.begin(), stall.end());
    int l = 0, r = stall[n - 1] - stall[0], mid;
    while (r >= l)
    {
        mid = (l + r) / 2;
        if (check(mid))
            l = mid + 1;
        else
            r = mid - 1;
    }
    cout << l - 1 << endl;
    system("pause");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

jian圣楠

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值