【ZOJ】1457 &【UVA】524Prime Ring Problem素环问题

【ZOJ】1457 &【UVA】524Prime Ring Problem素环问题

原题

Time Limit: 10000 ms
Memory Limit: 32768 KB

Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

在这里插入图片描述

Input

n (0 < n < 20)

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2


翻译

输入正整数 n,把整数 1,2,…,n 组成一个环,使得相邻两个整数之和均为素数。输出时,从整数 1 开始逆时针排列。同一个环恰好输出一次。n≤20,保证一定有解。

多组数据,读入到 EOF 结束。

第 i 组数据输出前加上一行 Case i:

相邻两组数据中间加上一个空行。

输入输出样例

输入
6
8
输出
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2


思路

若n为奇数,跳过。
因为奇数无解。
若n为偶数,用DFS暴力枚举。
注意格式,末尾无空格,两个数据之间有换行。

代码

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int n,b[25];
bool c[25],z[41]={0,0,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1,0,0,0,0,0,1,0,0,0};
void DFS(int dep)
{
	int i;
	if(dep>n)//到达长度 
	{
		if(z[b[n]+1])
		{
			printf("1");
			for(i=2;i<=n;i++)
				printf(" %d",b[i]);
			printf("\n");
		}
		return;
	}
	for(i=2;i<=n;i++)//扩展 
		if(c[i]&&z[b[dep-1]+i])
		{
			c[i]=0;
			b[dep]=i;
			DFS(dep+1);
			c[i]=1;
		}
	return;
}
int main()
{
	int i;
	b[1]=1;
	for(i=1;cin>>n;i++)
	{
		memset(c,true,sizeof(c));
		c[1]=0;
		printf("Case %d:\n",i);
		if(!(n&1))//跳过奇数 
			DFS(2);
		printf("\n");
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值