hdu-4576 Robot(DP+滚动数组)

Problem Description
Michael has a telecontrol robot. One day he put the robot on a loop with n cells. The cells are numbered from 1 to n clockwise.
在这里插入图片描述

At first the robot is in cell 1. Then Michael uses a remote control to send m commands to the robot. A command will make the robot walk some distance. Unfortunately the direction part on the remote control is broken, so for every command the robot will chose a direction(clockwise or anticlockwise) randomly with equal possibility, and then walk w cells forward.
Michael wants to know the possibility of the robot stopping in the cell that cell number >= l and <= r after m commands.

Input
There are multiple test cases.
Each test case contains several lines.
The first line contains four integers: above mentioned n(1≤n≤200) ,m(0≤m≤1,000,000),l,r(1≤l≤r≤n).
Then m lines follow, each representing a command. A command is a integer w(1≤w≤100) representing the cell length the robot will walk for this command.
The input end with n=0,m=0,l=0,r=0. You should not process this test case.

Output
For each test case in the input, you should output a line with the expected possibility. Output should be round to 4 digits after decimal points.

Sample Input

3 1 1 2
1
5 2 4 4
1
2
0 0 0 0

Sample Output

0.5000
0.2500

题意

1到n形成一个环,机器人从一号点出发,有m条指令,给定每次走的长度,方向随机(顺时针或逆时针),问最后在某个区域内(l-r)的概率是多少。

代码

#include<iostream>
#include<cstdio>
using namespace std;
double dp[2][220];
int main()
{
	//freopen("data.txt","r",stdin);
	int n,m,l,r,c;
	while(scanf("%d%d%d%d",&n,&m,&l,&r)==4){
		if(n==0&&m==0&&l==0&&r==0) break;
		dp[0][0]=1;
		for(int i=1;i<n;i++) dp[0][i]=0;
		int now=0;
		while(m--){
			scanf("%d",&c);
			for(int i=0;i<n;i++)
			dp[now^1][i]=dp[now][(i-c+n)%n]*0.5+dp[now][(i+c)%n]*0.5;
			now^=1;//now表示现在的状态,根据亦或符号,可以实现0-1-0-1交换,根据now推出下一状态 
		}
		double ans=0;
		for(int i=l-1;i<r;i++)
			ans+=dp[now][i];
		printf("%.4lf\n",ans);
	}
		return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值