PAT A1031 Hello World for U (20分)

75 篇文章 0 订阅

PAT A1031 Hello World for U (20分)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h d
e l
l r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​ characters, then left to right along the bottom line with n2​​ characters, and finally bottom-up along the vertical line with n3​​ characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n1​​ =n3​ =max { k | k≤n2 for all 3≤n2≤N } with n1 +n2 +n​3 −2=N.

Input Specification:
Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:
For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!
Sample Output:
h !
e d
l l
lowor

以下是AC的代码:

#include<cstdio>
#define maxn 100
int main(void){
	char cha[maxn];
	int i=0;
	scanf("%c",&cha[0]);
	while(cha[i] != '\n'){
		scanf("%c",&cha[++i]);
	}
	int len=i;//最后一个是'\n' ,但i是从0开始的; 
	int n1,n2;
	n1=(len+2)/3;//利用int 的特性算n1 
	n2=len+2-n1*2;
	for(int j=0;j<n1-1;j++){
		printf("%c",cha[j]);
		for(int k=0;k<n2-2;k++)printf(" ");
		printf("%c\n",cha[len-j-1]);
	}
	for(int j=n1-1;j<n1+n2-1;j++)printf("%c",cha[j]);
	return 0;
}

思路:
这道题的关键点在于n1,n2,n3的计算,因为n1,n3满足小于n2的最大数,这里可以用int 的特性,因为当n1,n2,n3相等时,n1+n2+n3-2=N,可以用n1=(N+2)/3,N中减去n1,n3剩下的部分就是n2。
第二个地方是:因为扫入时我们使用的while循环是判定数组内cha[i]==’\n’才跳出循环,出来时应注意cha[i]是\n而不是最后一个字符。因为i是从0开始的,这里i值即为字符个数。

另外答案这里输入是用的gets,实测用gets会编译错误。PAT屏蔽了gets,百度了一下好像是为了维持不同环境下的公平性。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值