PAT A1095 Cars on Campus (30 分)

75 篇文章 0 订阅
该博客讨论了一个停车管理系统的实现,包括输入输出规格、处理查询的方法以及使用排序和映射数据结构进行优化。在处理车辆进出记录时,通过筛选有效记录并更新车辆停车时间,最终找到停车最久的车辆。在查询阶段,由于查询时间点的有序性,避免了重复遍历,提高了效率。
摘要由CSDN通过智能技术生成

PAT A1095 Cars on Campus (30 分)

Zhejiang University has 8 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:
Each input file contains one test case. Each case starts with two positive integers N (≤10^ ​4​ ), the number of records, and K (≤8×10^ 4​) the number of queries. Then N lines follow, each gives a record in the format:

plate_number hh:mm:ss status
where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each in record is paired with the chronologically next record for the same car provided it is an out record. Any in records that are not paired with an out record are ignored, as are out records not paired with an in record. It is guaranteed that at least one car is well paired in the input, and no car is both in and out at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.

Output Specification:
For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:
16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00
Sample Output:
1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09
以下是AC的代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<string>
#include<map> 
using namespace std;
const int maxn = 10010;
struct car{
	char id[10];
	int time;
	char status[10];
}c[maxn],valid[maxn];
bool cmpidntime(car a,car b){
	if(strcmp(a.id,b.id) != 0) return strcmp(a.id,b.id)<0;
	else return a.time<b.time;
}
bool cmptime(car a,car b){
	return a.time<b.time;
}
int timetoint(int hh,int mm,int ss){
	int time = hh*60*60+mm*60+ss;
	return time;
}
int main(void){
	int n,k;
	scanf("%d%d",&n,&k);
	int hh,mm,ss;
	for(int i=0;i<n;i++){
		scanf("%s%d:%d:%d%s",&c[i].id,&hh,&mm,&ss,&c[i].status);
		c[i].time=timetoint(hh,mm,ss);
	}
	sort(c,c+n,cmpidntime);

	int num=0,maxtime=-1;
	map<string,int> parktime;
	for(int i=0;i<n-1;i++){
		if(strcmp(c[i].id,c[i+1].id)==0&&strcmp(c[i].status,"in")==0&&strcmp(c[i+1].status,"out")==0){
			//有效记录; 
			valid[num++]=c[i];
			valid[num++]=c[i+1];
			if(parktime.count(c[i].id)==0){
				parktime[c[i].id] = 0;
			}//如果没有parktime的记录,初始化为0; 
			parktime[c[i].id]+=c[i+1].time-c[i].time;//更新parktime; 
			maxtime=max(parktime[c[i].id],maxtime);//更新maxtime; 
		}
	}
	sort(valid,valid+num,cmptime);//在有效记录中按照时间排序;
	
	int carnum=0,now=0,time;  
	for(int i=0;i<k;i++){//处理 valid任一时刻carnum; 
		scanf("%d:%d:%d",&hh,&mm,&ss);
		time = timetoint(hh,mm,ss);
		while(now<num && valid[now].time<=time){
			if(strcmp(valid[now].status,"in")==0){
				carnum++;
			}else{
				carnum--;
			}
			now++;
		}
		printf("%d\n",carnum);
	}
	//接下来输出停车时间最长的车牌号;
	//选择便利parktime而不是valid的原因是 parktime作为一个map,里面的key都是唯一的; 
	for(map<string,int>::iterator i=parktime.begin();i!=parktime.end();i++){
		if(i->second == maxtime){
			printf("%s ",i->first.c_str());
		}
	}
	printf("%02d:%02d:%02d",maxtime/3600,maxtime%3600/60,maxtime%60);
	return 0;
}

思路:
排序题;这里采用 map<string,int>parktime,来存储每个车牌号对应的停车时间,因为map的特性是每对映射键值 key 是唯一的,并且会自动有序。
另外在查询的阶段,由于题目说了查询的时间点是递增有序的,所以不用每次循环结束重置now为0,否则会运行超时。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值