ZOJ Prime Ring Problem

A ring is compose of n circles as shown in diagram. Put natural
number 1, 2, …, n into each circle separately, and the sum of numbers in two
adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input

n (0 < n < 20)

Output

The output format is shown as sample below. Each row represents a series of
circle numbers in the ring beginning from 1 clockwisely and anticlockwisely.
The order of numbers must satisfy the above requirements. Print solutions
in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

思路

人工打出50以内质数表,然后dfs枚举所有情况+可行性剪枝(老师说这破题和图论有关系??没发现
Code:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<string>
using namespace std;
bool b[30],o[50]={1,1,0,0,1,0,1,0,1,1,1,0,1,0,1,1,1,0,1,0,1,1,1,0,1,1,1,1,1,0,1,0,1,1,1,1,1,0,1,1,1,0,1,0,1,1,1,0,1,1};
int a[30],n;
void dfs(int x)
{
 if (x==n)
 {
  if (o[a[x-1]+a[0]]==0)
  {
   cout<<a[0]; 
   for (int i=1;i<x;i++) cout<<' '<<a[i];
   cout<<endl;
  }
  return;
 }
 for (int i=2;i<=n;i++)
 {
  if (b[i]!=1&&o[a[x-1]+i]==0)
  {
   b[i]=1;
   a[x]=i;
   dfs(x+1);
   b[i]=0;
  }
 }
 return;
}
int main()
{
 int o=1;
 while (cin>>n)
 {
  cout<<"Case "<<o<<':'<<endl;
  memset(b,0,sizeof(b));
  if (n%2==1)
  {
   o++;
   cout<<endl;
   continue;
  }
  b[1]=1;
  a[0]=1;
  o++;
  dfs(1);
  cout<<endl;
 }
 return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值