1090 Highest Price in Supply Chain (25 分)

1090 Highest Price in Supply Chain (25 分)
A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:
Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤10 的5次方 ), the total number of the members in the supply chain (and hence they are numbered from 0 to N−1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number S i is the index of the supplier for the i-th member. S root
​ for the root supplier is defined to be −1. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 10 的10次方 .

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2

读题可知,这一题考树,而且要求深度最大的叶子节点的个数还有计算P的值
每隔一层,P就会增加r%。
用DFS遍历树,再遇到叶子节点的时候是DFS递归边界,并且做相关的处理就好

#include <iostream>
#include <vector>
#include <cmath>
using namespace std;
const int maxn = 100010;
int n;
double p,r,rp;
vector<int> vt[maxn];
int num = 0;
int maxD = 0;
void DFS(int root, int depth)
{
	if (vt[root].size() == 0)
	{
	//不是最深的的叶子节点把计数器归零
		if (depth > maxD)
		{
			maxD = max(depth, maxD);
			num = 0;
		}
		if (maxD == depth)
			num++;
		return;
	}
	for (int i = 0; i < vt[root].size(); i++)
	{
		DFS(vt[root][i], depth + 1);
	}
}
int main()
{
	int root;
	int temp;
	double ans;
	cin >> n >> p >> r;
	rp = 1.0 * r / 100;
	for (int i = 0; i < n; i++)
	{
		cin >> temp;
		if (temp == -1)
			root = i;
		else
			vt[temp].push_back(i);
	}
	DFS(root, 0);
//	cout << maxD << " " << num << endl;
	ans = p * pow(1 + rp, maxD);
	printf("%.2lf %d", ans, num);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值