PAT 1036 Boys and Girls

1036 Boys vs Girls

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's namegenderID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF​−gradeM​. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

总结:这题不难,容易写,直接将所有数据输入的时候直接处理,不需要保存(在线处理)

代码:

#include <iostream>
using namespace std;

int main(){
    int n;
    cin >> n;
    
    string s,id,fname,mname;
    char c;
    int t,fm=-1,mm=0x3f3f3f3f;//fm表示女生最大值,mm表示男生最小值
    bool f=false,m=false;
    for(int i=0;i<n;i++){
        cin >> s >> c >> id >> t;
        if(c=='F'){
            f=true;
            if(fm<t){
                fm=t;
                fname=s+' '+id;
            }
        }
        else{
            m=true;
            if(mm>t){
                mm=t;
                mname=s+' '+id;
            }
        }
    }
    f==true?cout << fname << endl:cout << "Absent" << endl;
    m==true?cout << mname << endl:cout << "Absent" << endl;
    if(!f || !m)    printf("NA");
    else printf("%d\n",fm-mm);
    
    return 0;
}

好好学习,天天向上!

我要考研!

2022.11.4

/*
    思路:找出女生里面的最高分,找到男生里的最低分,(找最值的时候需要加上性别进行限制),最后根据分数来判断
    是否有找到最低分的男生,最高分的女生
*/
#include <iostream>
using namespace std;

int main(){
    int maxg=-1,ming=101,n;
    string maxname,maxid,minname,minid;
    scanf("%d",&n);
    
    string name,id;
    char c;
    int g;
    for(int i=0;i<n;i++){
        cin >> name >> c >> id >> g;
        if(g>maxg && c=='F'){//女生里的最高分
            maxg=g;
            maxid=id;
            maxname=name;
        }
        else if(g<ming && c=='M'){//男生里的最低分
            ming=g;
            minid=id;
            minname=name;
        }
    }
    bool sign=false;
    if(maxg==-1){
        printf("Absent\n");
        sign=true;
    }
    else cout << maxname << ' ' << maxid << endl;
    if(ming==101){
        printf("Absent\n");
        sign=true;
    }
    else cout << minname << ' ' << minid << endl;
    if(sign)    printf("NA\n");
    else printf("%d\n",maxg-ming);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值