Pat1036 Boys vs Girls

该程序旨在找出一组学生数据中女性最高成绩与男性最低成绩的差异。输入包含学生的姓名、性别、ID和成绩,程序会分别记录最高女生成绩和最低男生成绩。如果缺少某种性别的学生,则输出'Absent',最后输出两者成绩之差。示例输入包括3名学生,程序正确地输出了最高女生成绩、最低男生成绩及其差异。对于只有1名男性的输入,程序也适当地处理了缺失的女性数据。
摘要由CSDN通过智能技术生成

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:
Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:
For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade
​F
​​ −grade
​M
​​ . If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:
3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95
Sample Output 1:
Mary EE990830
Joe Math990112
6
Sample Input 2:
1
Jean M AA980920 60
Sample Output 2:
Absent
Jean AA980920
NA

题目思路:

  1. 题目思路类似sign in sign out的题目
  2. 首先存放男id,女id,男分数,女分数
  3. 男分低了更新男id并记录分数,女分高了更新女id并记录分数(此处为了代码的方便给了一个不可能出现INF值)
  4. 按照上面的思路循环处理每一条记录
  5. 根据存放的数据进行对应的输出
#include <iostream>

using namespace std;

int main(){
    int INF = -1000000;
    int n, boy_score = INF, girl_score = INF;
    string boy_name, girl_name, boy_id, girl_id;

    cin >> n;
    for(int i = 0;i < n; i++){
        string name, male, id;
        int score;
        cin >> name >> male >> id >> score;
        if(male == "F"){
            if(girl_score == INF || score > girl_score){
                girl_name = name;
                girl_id = id;
                girl_score = score;
            }
        }else{
            if(boy_score == INF || score < boy_score){
                boy_name = name;
                boy_id = id;
                boy_score = score;
            }
        }
    }
    if(girl_score == INF){
        cout << "Absent" << endl;
    }else{
        cout << girl_name << ' ' << girl_id << endl;
    }
    if(boy_score == INF){
        cout << "Absent" << endl;
    }else{
        cout << boy_name << ' ' << boy_id <<endl;
    }
    if(girl_score == INF || boy_score == INF){
        cout << "NA" << endl;
    }else{
        cout << girl_score - boy_score << endl;
    }
}

改良代码:

#include <iostream>

using namespace std;

int main()
{
    int n;

    string girl_name, girl_id;
    int girl_score;
    string boy_name, boy_id;
    int boy_score;

    cin >> n;
    for (int i = 0; i < n; i ++ )
    {
        string name, sex, id;
        int score;
        cin >> name >> sex >> id >> score;

        if (sex == "F") 
        {
            if (girl_name.empty() || girl_score < score)
            {
                girl_name = name;
                girl_id = id;
                girl_score = score;
            }
        }
        else 
        {
            if (boy_name.empty() || boy_score > score)
            {
                boy_name = name;
                boy_id = id;
                boy_score = score;
            }
        }
    }

    if (girl_name.empty()) puts("Absent");
    else cout << girl_name << ' ' << girl_id << endl;

    if (boy_name.empty()) puts("Absent");
    else cout << boy_name << ' ' << boy_id << endl;

    if (girl_name.size() && boy_name.size()) cout << girl_score - boy_score << endl;
    else cout << "NA" << endl;

    return 0;
}

Y总的代码写的漂亮,拿来多看看多学学,不论如何一切以他的代码为最优解

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值