PAT 1094 The Largest Generation(树的遍历DFS)

1094 The Largest Generation

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4

总结:这次出了两个问题,一个是如果只有一层的话,那整棵树上只有一个根节点,最大值表示为1个人在第一层 (1,1),还有一个就是最后在找哪一代人数最多的循环有问题,范围太小了,m个人有孩子不代表就只有m代人,而是有m+1代人 

代码(dfs):

#include <iostream>
#include <vector>
using namespace std;

int maxdepth,maxnum;
int n,m;
int a[110];//表示每一层有多少个孩子
bool st[110];
vector<vector<int>> v(110);

void dfs(int t,int depth){
    if(depth!=1) a[depth]++;
    
    for(int i=0;i<v[t].size();i++)
        dfs(v[t][i],depth+1);
}

int main(){
    scanf("%d%d",&n,&m);
    
    int t,w,q;//表示当前这个人有多少个孩子
    for(int i=0;i<m;i++){
        scanf("%d %d",&w,&t);
        for(int j=0;j<t;j++){
            scanf("%d",&q);
            v[w].push_back(q);
        }
    }
    
    a[1]=1;
    dfs(1,1);
    for(int i=1;i<=m;i++){
        if(a[i]>maxnum){
            maxnum=a[i];
            maxdepth=i;
        }
    }
    if(n==1)    printf("1 1\n");
    else printf("%d %d\n",maxnum,maxdepth);
    return 0;
}

 bfs:利用了额外的level数组来存放每一个点的所在的层数

#include <iostream>
#include <queue>
#include <vector>
using namespace std;

vector<vector<int>> v(100);
int a[100];
int level[100];//表示每个点所在的层数,下标表示哪一个点
int n,m;
int maxdepth=1,maxnum;

int main(){
    scanf("%d%d",&n,&m);
    
    int t,w,r;
    for(int i=0;i<m;i++){
        scanf("%d%d",&t,&w);
        for(int j=0;j<w;j++){
            scanf("%d",&r);
            v[t].push_back(r);
        }
    }
    level[1]=1;
    queue<int> q;
    q.push(1);
    
    while(q.size()){
        int index=q.front();
        q.pop();
        
        a[level[index]]++;
        for(int i=0;i<v[index].size();i++){
            level[v[index][i]]=level[index]+1;
            q.push(v[index][i]);
        }
    }
    for(int i=1;i<=m+1;i++){
        if(a[i]>maxnum){
            maxnum=a[i];
            maxdepth=i;
        }
    }
    printf("%d %d\n",maxnum,maxdepth);
    return 0;
}

好好学习,天天向上!

我要考研!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值