PAT 1124 Raffle for Weibo Followers

1124 Raffle for Weibo Followers

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo -- that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John's post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going... instead.

Sample Input 1:

9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain

Sample Output 1:

PickMe
Imgonnawin!
TryAgainAgain

Sample Input 2:

2 3 5
Imgonnawin!
PickMe

Sample Output 2:

Keep going...

 总结:这道题目还是比较简单的,之前也做过,使用map存储下来已经获奖的ID即可,判断当前这个ID是否获奖,如果未获奖则直接跳跃指定的跳数,如果已获奖,判断下一个id是否获奖

代码:

#include <iostream>
#include <map>
using namespace std;

int main(){
    int m,n,s,cot=0;
    map<string,int> p;
    scanf("%d%d%d",&m,&n,&s);
    string t[1010];
    for(int i=0;i<m;i++)    cin >> t[i];
    for(int i=s-1;i<m;i+=n){
        if(p[t[i]]!=1){
            p[t[i]]=1;
            cot++;
            cout << t[i] << endl;
            continue;
        }
        else{
            while(1){
                i++;
                if(p[t[i]]!=1){
                    cot++;
                    cout << t[i] << endl;
                    p[t[i]]=1;
                    break;
                }
            }
        }
    }
    if(cot==0)  printf("Keep going...\n");
    return 0;
}

柳神的代码:

还是依旧的简洁明了!

#include <iostream>
#include <map>
using namespace std;
int main() {
    int m, n, s;
    scanf("%d%d%d", &m, &n, &s);
    string str;
    map<string, int> mapp;
    bool flag = false;
    for (int i = 1; i <= m; i++) {
        cin >> str;
        if (mapp[str] == 1) s = s + 1;
        if (i == s && mapp[str] == 0) {//s表示的是下一个抽奖的的位置(关键)
            mapp[str] = 1;
            cout << str << endl;
            flag = true;
            s = s + n;
        }
    }
    if (flag == false) cout << "Keep going...";
    return 0;
}

好好学习,天天向上!

我要考研!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值