106 大整数相加

问题描述 :

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

输入说明 :

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

输出说明 :

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

输入范例 :

2
1 2
112233445566778899 998877665544332211
输出范例 :

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

c++:

#include <bits/stdc++.h>
using namespace std;

int main()
{	
	int n;
	cin>>n;
	for(int k=1;k<=n;k++){
		char a[1000];
		char b[1000];
		cin>>a;
		cin>>b;
		int count=1;
		int carry[10]={0};
		char num1[1000]={'0'};
		char num2[1000]={'0'};
		int len1=strlen(a);
		int len2=strlen(b);
		int result[1000]={0};
		int len3=0; int x=0;//存放进位; 
		for(int i=0;i<len1;i++){
			num1[len1-1-i]=a[i]-'0';//将字符转化为十进制并把个位放在开头 
		} 
		for(int i=0;i<len2;i++){
			num2[len2-1-i]=b[i]-'0';
		} 
		while(len3<len1||len3<len2){
			result[len3]=num1[len3]+num2[len3]+x;
			x=result[len3]/10;
			result[len3]=result[len3]%10;//实际的值 
			len3++;
		}
		carry[len3]=x;
		if(carry[len3]==0){
			len3--;//除去最高位 
		}else{
			result[len3]=carry[len3];
		}
		printf("Case %d:\n",k);
		printf("%s + %s = ",a,b);
		for(int i=len3;i>=0;i--){
			printf("%d",result[i]);
		}
		printf("\n\n");		
	}
	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

天堂不能没有你

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值