1008 Elevator

题目来源:PAT (Advanced Level) Practice 1008 Elevator (20 分)

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

words:

elevator 电梯,升降机    make up 由...组成     danote at 表示   sepecified 具体的,一定的  move up 上升   move down 下降    stay for 停留,等待  

fulfill 完成,满足,实现    return to 返回

思路:

1. 本题要求计算出电梯的运行时间,其中一开始电梯在0 floor,然后按照输入的n个楼层分别进行模拟运行,最后求出总运行的时间;

2. 电梯上升一层需要6s,下降一层需要4s,到目的楼层停靠一次需要5s,每一次电梯的运行时间等于上升/下降时间加停靠时间;

3. 电梯有可能在一个楼层连续停靠多次(即输入的楼层中有连续相同的数),此时只需要多次计算停靠时间即可;

 

#include <iostream>   vxgzh:xtsn
using namespace std;
#include <algorithm>
#define N   105

int main()
{
	int n,i,j,a[N];
	cin>>n;
	for(i=0;i<n;i++)
		cin>>a[i];
	int time=0;   //total time 
	int position=0;   //now floor numner of elevator in 
	for(i=0;i<n;i++)
	{
		if(a[i]>position)   //need to move up  and stop
		{
			time+=(a[i]-position)*6+5;
			position=a[i];
		}
		else if(a[i]<position)  //need to move down and stop 
		{
			time+=(position-a[i])*4+5;
			position=a[i];
		}
		else time+=5;    //need to stop 
	}	
	cout<<time<<endl;	
	
	return 0;
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值