PAT甲级1008 Elevator C++/C语言

1008 Elevator
分数 20
作者 CHEN, Yue
单位 浙江大学
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:
Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:
For each test case, print the total time on a single line.

Sample Input:
3 2 3 1
Sample Output:
41
所需变量

int N;//代表需要在多少个楼层停靠

int a[100];//代表每次所需要停靠的楼层

int sum;//代表需要多少时间

思路:我们首先获取N,然后输入N个数,然后再进行判断他是上楼还是下楼,然后再决定所需要的秒数。
代码如下(编译器是dev,语言是C++):

#include<iostream>
using namespace std;
int N,a[100],sum = 0;
int main(){
    cin>>N;
    for(int i = 0;i<N;i++){
        cin>>a[i];
        if(i == 0){
            sum += 6*a[i] + 5;
        }else{
            if(a[i]>a[i-1]){
                sum += (a[i]-a[i-1])*6 + 5;
            }else if(a[i] == a[i-1]){
                sum += 5;
            }else{
                sum += (a[i-1]-a[i])*4 + 5;
            }
        }
    }
        printf("%d\n",sum);
    return 0;
}

PAT

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值