【PAT(甲级)】1008 Elevator

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

解题思路:

题目信息给的是电梯一开始在0层,上楼每上一层需要6秒,下楼每下一层需要4秒,每次完成任务时要在相应楼层停靠5秒。给你N个任务,让你求出电梯走完这些楼层需要多久的时间(最后一个任务也要算上停靠时长)。

很容易地就想到用一个time来存放总时长,然后上楼的计算就是(之后的楼层-之前的楼层)X 6+5,下楼的计算就是(之后的楼层-之前的楼层)的绝对值 X 4+5,然后输出总时间time就行。

易错点:

1. 楼层的停靠时间注意下,相当于每给你一个新的数字时才需要加上那停靠的5秒,然后结束的时候也需要算上最后一次电梯的停靠时间。

2. 注意一下上下楼的时间是不一样的记得区分。

3. 注意第一次电梯从0层开始。

代码:

#include<bits/stdc++.h>
#include<vector>
using namespace std;
int main(){
	int N;
	cin>>N;
	vector<int> n;
	for(int i=0;i<N;i++){//按照要求读取数据 
		int j;
		cin>>j;
		n.push_back(j);
	}
	int time=0;
	for(int i=0;i<N;i++){
		if(i==0){//电梯第一次从0层开始,单独情况处理 
			time+=n[i]*6+5;
		}
		else{
			if(n[i]-n[i-1]>0){//电梯向上走 
				time+=(n[i]-n[i-1])*6+5;
			}
			else{//电梯向下走 
				time+=abs(n[i]-n[i-1])*4+5;
			}
		}
	}
	cout<<time;
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值