1094 The Largest Generation (25 分)--PAT甲级(树的同层最大数)

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:
Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID’s of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
结尾无空行
Sample Output:
9 4
结尾无空行

题目分析:题目给出一棵树,求数的哪一层的结点数最多,并且输出树的高度。

可以使用dfs解决,level代表高度,再记录一个sum[110],将每层的结点累加进去。每次增加一个结点要和maxnum比较,更新。

#include<iostream>
#include<vector>
using namespace std;
vector<int> v[110];
int sum[110], maxnum, maxdepth;
void dfs(int root, int depth)
{
	sum[depth] ++;
	if(sum[depth] > maxnum){
		maxnum = sum[depth];
		maxdepth = depth;
	}
	if(v[root].size() == 0){
		return;
	}
	for(int i = 0; i < v[root].size(); i ++){
		dfs(v[root][i], depth + 1);
	}
}

int main(){
	int n, k;
	cin >> n >> k;
	for(int i = 0; i < k; i ++){
		int a, t, b;
		cin >> a >> t;
		for(int i = 0; i < t; i ++){
			cin >> b;
			v[a].push_back(b);
		}
	}
	dfs(1, 1);
	cout << maxnum << ' ' << maxdepth << endl;
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值