1140:验证子串(字符串查找函数)

1140:验证子串

时间限制: 1000 ms 内存限制: 65536 KB
提交数: 30032 通过数: 14372
【题目描述】
输入两个字符串,验证其中一个串是否为另一个串的子串。

【输入】
输入两个字符串, 每个字符串占一行,长度不超过200且不含空格。

【输出】
若第一个串s1是第二个串s2的子串,则输出(s1) is substring of (s2)

否则,若第二个串s2是第一个串s1的子串,输出(s2) is substring of (s1)

否则,输出 No substring。

【输入样例】
abc
dddncabca
【输出样例】
abc is substring of dddncabca

#include <bits/stdc++.h>
using namespace std;
int main()
{
	string a,b;
	cin>>a>>b;
	 string ::size_type idx;
	 idx=a.find(b);//在 a 中查找b 
	 if(idx!=string::npos)//表示能查到 
	 {
	 	cout<<b<<" is substring of "<<a<<endl;
	 }
	 else
	 {
	 	idx=b.find(a);
	 	if(idx!=string::npos)
	 	{
	 		cout<<a<<" is substring of "<<b<<endl;
		 }
		 else
		 cout<<"No substring"<<endl;
	 }
	return 0;
}

// 记一下,这种查找函数总数忘记

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值