Dragon Balls
Problem Description
Five hundred years later, the number of dragon balls will increase unexpectedly, so it’s too difficult for Monkey King(WuKong) to gather all of the dragon balls together.
His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities’ dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.
Input
The first line of the input is a single positive integer T(0 < T <= 100).
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.
Sample Input
2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1
Sample Output
Case 1:
2 3 0
Case 2:
2 2 1
3 3 2
思路:我的思路是不将Find函数和union函数进行优化,再加一个函数记录转移次数。
详细见代码
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
#include <cstring>
#include <cstdlib>
#include <math.h>
#include <queue>
#include <string.h>
using namespace std;
int a[100000];
int Find(int x)
{
while(1)
{
if(a[x]<0)
return x;
x=a[x];//不进行优化,方便记录转移次数
}
}
int fun(int x)
{
int y=0;
while(1)
{
if(a[x]<0)
return y;
x=a[x];
y++;//记录转移次数
}
}
void hebing(int y,int x)
{
x=Find(x);
y=Find(y);
a[x]+=a[y];//龙珠的数量转移
a[y]=x;//将后前一个并进后一个
}
int main()
{
int n,i;
scanf("%d",&n);
for(i=1;i<=n;i++)
{
memset(a,-1,sizeof(a));//将数组初始化为-1,记录龙珠的数量
int m,k,x,y,t,h,z;
scanf("%d%d",&m,&k);
char g;
printf("Case %d:\n",i);
while(k--)
{
getchar();//吞回车,如果这里用cin时间会超限
scanf("%c",&g);
if(g=='T')
{
scanf("%d%d",&t,&h);
hebing(t,h);
}
else if(g=='Q')
{
scanf("%d",&t);
z=fun(t);
x=Find(t),y=-a[Find(t)];
printf("%d %d %d\n",x,y,z);
}
}
}
}