HDU 3635 Dragon Balls

该博客讨论了一种算法问题,涉及到Monkey King(悟空)如何高效地收集分布在不同城市的龙珠。问题中,龙珠会在城市间转移,悟空计划使用飞行云来收集。博主提出了一个解决方案,利用并查集(Union-Find)数据结构来跟踪龙珠的位置和转移次数。在每一轮查询中,博主的算法能够快速回答悟空关于龙珠所在城市、城市内龙珠数量以及龙珠转移次数的问题。
摘要由CSDN通过智能技术生成

Dragon Balls

Problem Description
Five hundred years later, the number of dragon balls will increase unexpectedly, so it’s too difficult for Monkey King(WuKong) to gather all of the dragon balls together.

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities’ dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.

Input
The first line of the input is a single positive integer T(0 < T <= 100).
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)

Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.

Sample Input
2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1

Sample Output
Case 1:
2 3 0
Case 2:
2 2 1
3 3 2

思路:我的思路是不将Find函数和union函数进行优化,再加一个函数记录转移次数。
详细见代码

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
#include <cstring>
#include <cstdlib>
#include <math.h>
#include <queue>
#include <string.h>
using namespace std;
int a[100000];
int Find(int x)
{
    while(1)
    {
        if(a[x]<0)
            return x;
        x=a[x];//不进行优化,方便记录转移次数
    }
}
int fun(int x)
{
    int y=0;
    while(1)
    {
        if(a[x]<0)
           return y;
        x=a[x];
        y++;//记录转移次数
    }
}
void hebing(int y,int x)
{
    x=Find(x);
    y=Find(y);
    a[x]+=a[y];//龙珠的数量转移
    a[y]=x;//将后前一个并进后一个
}
int main()
{
    int n,i;
    scanf("%d",&n);
    for(i=1;i<=n;i++)
    {
        memset(a,-1,sizeof(a));//将数组初始化为-1,记录龙珠的数量
        int m,k,x,y,t,h,z;
        scanf("%d%d",&m,&k);
        char g;
        printf("Case %d:\n",i);
        while(k--)
        {
            getchar();//吞回车,如果这里用cin时间会超限
            scanf("%c",&g);
            if(g=='T')
            {
                scanf("%d%d",&t,&h);
                hebing(t,h);
            }
            else if(g=='Q')
            {
                scanf("%d",&t);
                z=fun(t);
                x=Find(t),y=-a[Find(t)];
                printf("%d %d %d\n",x,y,z);
            }
        }
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值